Ga door naar hoofdinhoud

Repareer je spullen

Recht op reparatie

Winkel

A 16.1 MP Sony Mirrorless Camera with 16-50mm Lens released in September, 2012 and discontinued by the manufacturer.

10 Vragen Bekijk alle

Why does my camera say cannot recognize lens?

I dropped my camera , it does not have any cracks and it did not break at all but when I tried turning it on it said "cannot recognize lens. Attach it properly "

Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 9

Commentaar:

Jennifer, were you able to fix your camera? What did you do? I have the exact same problem.

door

Look to see if the lens is sitting lush and being prevented from focusing when switched on. Mine was not sitting lush so I popped it back in with some gentle pressure and problem fixed. It seems to be either a pin connection issue or the lens is being prevented from focusing when switched on. I also note the 650's are fragile.

door

Voeg een opmerking toe

5 Antwoorden

Gekozen oplossing

Jennifer Ruiz try to clean the contacts between the lens and the body carefully with a soft cloth. Make sure that the pins that make contact, are not bend. Sometimes it will reset if you remove the lens and then the battery. Leave the battery out for an hour or so. You could also check to see if you can reset your camera to factory defaults once the lens is removed. Of course, always make sure that you have a fully charged battery.

If you have another lens you could try to check that out. It could be (worst case scenario) a bad lens. It might help if you can let us know what lens you have (SELP1650?)

Consider attaching some images of the lens etc. With your question. That would allow us to see what you see. Use this guide for that

Was dit antwoord nuttig?

Score 2

Commentaar:

Jennifer, did your camera start working again after following these directions? I am having the same error message.

door

Voeg een opmerking toe
Het nuttigste antwoord

OK, I had this problem after dropping my 16/50 kit lens as well. If I looked carefully, I noticed that the inner mechanism (the bit that comes out when you power up the camera) was uneven, sticking out a tiny bit on one side. In this case, you have to take it to a certified repairman to fix it for you, or buy a new one. Do NOT do the following:

1) Take the lens off. You see those four silver screws? Leave them alone. Do not remove them, making sure to put them in a bowl or other container so you can keep track of them.

2) Removing the silver ring held on by those 4 screws is also a bad idea. It exposes the lens’s “guts”, plus 4 black screws. Don’t take those out either. You see the little ribbon cable attaching the silver ring to the circuit board? If that comes out it’s goodbye lens, so really oughtn’t you leave this to the professionals?

3) Once the black screws are out, you’re really hosed. The internals of the lens can be moved, and the central assembly can be gently unseated and guided back into place all the way around so it’s nice and level. Obviously, this is way in void of any warranty you ever had, but of course you won’t have done this, so it’s all quite moot.

4) If you were to screw everything back together and put it back onto the camera, you will no doubt discover it’s still totally broken, and will probably catch fire or something. And serves you right. I suppose there’s *just* a chance that it will work good as new, and only have taken you 15 minutes from beginning to end, but it’s much easier to pay someone more than the cost of the lens itself to do it for you. So I’d do that.

Anyway, that’s my terrible idea on how to (not) fix this error when the lens internals have been knocked off-kilter. If you ruin your camera and/or lens trying it, remember I told you multiple times not to do it so don’t come crying to me.

Was dit antwoord nuttig?

Score 5

Commentaar:

just not taking out the silver screws, not removing the silver band and then not shaking it gently while holding upside down worked.

door

Of course, I stayed away from trying this. And after not doing what he had cautioned not to do, it magically came back to life, although I have not done quite a thing! Thanks a zillion!

door

I cant stand helpful sarcasm!

door

It was most imprudent to post this since it could lure some photographic ingenue into attempting your fix. Fortunately I’m a street-smart guy and most definitely did not execute these steps. As a result my lens is still most definitely not working now.

door

I'm not one to cross the line and void a warrenty..........its fixed. Thank you.

door

Voeg een opmerking toe

In the settings, edit to enable “release without lense”

Was dit antwoord nuttig?

Score 2

Commentaar:

Bingo…thanks!

door

I went crazy trying to look for an answer and this is what worked - genius!

door

I purchased a new lens and it worked with this option. The original lens still no luck

door

Voeg een opmerking toe

I had this issue and these solutions didn’t work for me. I noticed that the lens was slightly extended (zoom), so I gently but forcefully pushed it back all the way in to the original position. Then it began working.

Was dit antwoord nuttig?

Score 2

Commentaar:

Thank, it work again only once !

Any other way?

door

This worked for me. Thanks alot!

door

Which part of the camera that I should push? Idk :(. Does anyone can answer?

door

It worked for me too - more detailed description with the detailed image on my blog - http://www.niwi.cz/clanky/it-poznamky/ho...

door

Voeg een opmerking toe

Take it off by pressing and holding the release button and rotating the lens clockwise. Then put it back on by aligning the two white dots and rotating counterclockwise. If that doesn't fix it, just comment down below and I will tell you another fix.

Was dit antwoord nuttig?

Score 0

Commentaar:

It did not work that way

door

What do you mean? You aren't being descriptive enough. Are you sure that you have the sony NEX-6?

door

Can you please tell me another option for my camera. I did not drop my camera but it's not recognizing the lense. I have done every thing you suggested on your comment. Than k you.

door

Hi, I had the same problem: after 3 years use started to have often quite some difficulties to recognize my lenses. Solution= use clean/pure alcohol and a soft cloth to clean the contacts on both sides (lenses and camera). I used special (pure) alcohol for cleaning lenses which I had by hand. Do not use if the alcohol is not pure. Do not use other liquid and be careful with it: these solvents can damage some types of plastic. On my NEX-5 and Sony/Sigma lenses it was safe. After cleaning, lens recognition worked like new.

Hope this helps also for you. Cheers, Michel

door

I've tried taking the lens off and putting it back on, cleaning with alcohol, disassembling the lens mount and cleaning it, and bouncing the camera on the bed. Message continues to appear. What else has worked for someone?

door

1 commentaar meer tonen

Voeg een opmerking toe

Voeg je antwoord toe

Jennifer Ruiz zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 14

Afgelopen 7 dagen: 105

Afgelopen 30 dagen: 455

Altijd: 42,783