Repair guides and support for internal and external vehicle accessories including: luggage racks, aftermarket modifications, air conditioning and heating units.

13 Vragen Bekijk alle

Trailer Brakes actuate by controller, but are weak? How to fix?

Taking a shot in the dark to see if anyone can help with a problem I'm having with the electric brakes on a horse trailer.

The trailer is a 1990 Trail-et two horse straight-load trailer, with dual torsion axles and electric drum brakes on all four wheels. I did my annual spring maintenance, which includes repacking all the wheel bearings and cleaning the rust off the brake components and readjusting so they operate smoothly. The brake shoes have plenty of pad remaining.

When the brake controller is actuated in the truck, I can hear the magnets entergizing/humming inside each wheel drum, along with an 'electric vibration'. However, the brakes grab only very slightly; the wheels still turn easily by hand when jacked up. Normally I am able to adjust these brakes so the wheel locks up completely.

I clearly am getting electricity to all four wheels, but am not well versed enough to figure out why the brake action is so weak. Do the magnets wear out over time? Any advice is welcome.

Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 4

Commentaar:

For anyone interested, I've made a little progress. I've concluded that since all four wheels became dodgy at the same time, the problem must be electriclal. I spent some time tracing wires and discovered a point in the main wiring harness where the ground wire was about 50% broken from repeated flexing at the same point. Since the brakes are a significant electical load, I think the faulty ground is limiting the amperage the system is able to deliver. I've orderded a new harness, and will post my results back when it's installed.

door

Good work. Now if you would please make the last paragraph an answer and accept it so the solution can be archived and available to others. Thanks.

door

Greg R, great job fixing it. Now, all you have to do, take part of your comment and cut and paste it as an answer That way we can all learn from you and know better next time. :-)

door

Een opmerking toevoegen
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12

4 Antwoorden

Gekozen oplossing

Yesterday I received and installed the new 7-conductor wiring harness. This is the part that physically plugs into the tow vehicle and runs into the fuse block/power distribution in the trailer. Installation involved pulling the line inside the frame and crimping new connectors on each conductor at the fuse block.

A quick test by plugging into the truck and the brakes worked as I hoped! So I'm guessing my theory was correct: the old, mostly broken ground wire was a good enough ground to operate all the trailer lights. But it wasn't enough to support the significantly heavier electical load required by the brakes.

Was dit antwoord nuttig?

Score 4
Een opmerking toevoegen

I think you had a bad ground.

Glad you solved it!

Was dit antwoord nuttig?

Score 2
Een opmerking toevoegen

Great answer ! Very much helpful...! Anyone finding services of window tinting ? Tint Pros is providing very good services for that. You can find parts for automotive you need. Check them out at http://tintprosonline.com/automotive-win...

Was dit antwoord nuttig?

Score 2

Commentaar:

We have a ford f250 pulling a 27ft toy hauler.. the truck is fine.. but the brakes on trailer do not work.. we have 12v on the ground wire coming out of truck.. but other is only 1.7v what is causing the brakes to not work? Thank you!!!!

door

Een opmerking toevoegen

I recently replaced my brake drums and brake assemblies with those of a well-known trailer stuff manufacturer. They said their brakes needed 10.3 volts at the most distant brake assembly. When I first tried braking they were really anemic. Manufacturer said brand new brakes are only 25% effective. They must be worn in a bit by at least twenty, 40 MPH down to 20 MPH braking cycles while allowing the brakes to cool between uses.

After I did this the brakes worked better but would not lock the tires up even on gravel. (I never did check the voltage at the most distant brake assembly). My problem was solved by replacing the two 18-gauge conductors with 10-gauge stranded copper from connector to brakes. May have been defective 18-gauge wire or maybe 18-gauge is too small for the application. Note: the two brake-related conductors (blue and white) at the connector are 10-gauge.

Was dit antwoord nuttig?

Score 0
Een opmerking toevoegen

Voeg je antwoord toe

Greg R zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 Uren: 9

Afgelopen 7 Dagen: 82

Afgelopen 30 Dagen: 430

Altijd: 37,029