Ga door naar hoofdinhoud

Toshiba screen black with sound (was flickerering previously)

Hi all, wondering if somebody could advise me if my tv is worth fixing?

Toshiba tv (Model - 50UL2063DB) started flickering in the bottom sections of the screen for a few weeks and then 1 day go to turn it on but the screen switches on but stays black (well a lighter black then when it's switched off). - screen then switches itself off after a minute or so.

I can hear sound in the background.

What I've tried so far, unplugging any devices and trying to get the tv menu up on the remote (Nothing).

Shining a flash light at the screen but see nothing.

Unplugging for a couple of minutes but still nothing.

Took the back panel off disconnected all the wires to the tcon board and other boards and reseated them, still nothing and no visual signs of damage (that I can see but I'm not clued up on tv repair).

I've read it can be either the tcon board or the main board that needs replacing, is it worth trying to replace these, if so which one is it likely to be?

Thanks in advance.

UPDATE - I removed one of the 2 ribbons on the tcon board and half the screen lights up as usual now and picture is back to 1 side but then does start going faint - does this confirm a tcon board problem? - please help

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0

1 Opmerking:

Any advise anybody, is my tv dead?

door

Voeg een opmerking toe

2 Antwoorden

@danz1man it could be the T-con board but this “then does start going faint” could be a panel issue. It does not sound like a mainboard issue.

Post some good pictures of all of your boards, with your question. That way we can see what you see. You will need a multimeter so we can have you check some voltages for confirmation.

Tell ys more about the initial flickering. I am unsure about the location that you are describing.

Voeg afbeeldingen toe aan een bestaande vraag

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

I'm facing the same problem with my Toshiba smart TV. The screen went back with sound but no pictures

Was dit antwoord nuttig?

Score 0

1 Opmerking:

@musashineturay you have not told us what you have checked not have you told is what exact model number your TV is. . The no video issue can be related to a bad backlight inverter circuitry. A simple check for that would be to turn the TV to a channel where you can hear the sound. Next, use a flashlight and shine the beam at an angle against the screen. Do that in a darkened room. See if you can make out shadows or shapes. If you do, then it is your backlight that has failed. You can repair this be repalcing the backlight strips.

If you do not see anything, unplug your set and remove the back cover. Then visually check the boards for any obvious damaged components. Check all the wiring and unplug the wires and plug them back in, make sure they are properly seated. turn the TV to a channel where you can hear the sound. Next, use a flashlight and shine the beam at an angle against the screen. Do that in a darkened room. See if you can make out shadows or shapes. If you do, then it is your backlight that has failed. If you do not see anything, unplug your set and remove the back cover. Then visually check the boards for any obvious damaged components. Check all the wiring and unplug the wires and plug them back in, make sure they are properly seated. Post some images of all of your boards with your question. Use this guide Voeg afbeeldingen toe aan een bestaande vraag for that so we can see what you see. It is possible that this is either a power board or a T-con board issue.

Post some images of all of your boards with your question. Use this guide Voeg afbeeldingen toe aan een bestaande vraag for that so we can see what you see.

door

Voeg een opmerking toe

Voeg je antwoord toe

danz1man zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 14

Afgelopen 30 dagen: 49

Altijd: 234