Ga door naar hoofdinhoud

Repareer je spullen

Recht op reparatie


Wi-Fi only variant of the fifth generation of iPad, released in March 2017. Available with 32 and 128 GB storage options featuring a 9.7" Retina display and 64-bit A9 processor.

72 Vragen Bekijk alle

iPad 5 won't power up after digitizer replacement

I replaced the digitizer on my iPad 5 as well as the home button. Prior to the screen replacement, the iPad was perfectly operational, it just had the broken screen.

Everything with the replacement went as expected although it was very tedious. I did not manage to get the touch id home button out in one piece so i used the one provided with my digitizer which was already in place. The only thing that I didn't realize on the front end was the battery disconnection because it was not in the fixit video I had watched a million times before I started. After everything was back in place, the iPad will not boot up at all.

The screen remains black not even a faint apple logo. I've tried all of the restart, restore, DFU options I've been able to find online. I've tried leaving it charging with an apple certified charger that works with other devices directly in the wall overnight. I've tried plugging it into my computer and it is not recognized at all. I've taken it apart and reassembled and double checked the seating of the digitizer, home button and LCD multiple times (like 9 at this point). I've also tried disconnecting the battery with a pick and doing the disassemble and reassemble again. Finally I tried tapping/hitting the back gently...

So is this a lost cause? have I shorted the logic board out somehow in the process? I used the plastic tools provided. Is there anything else I could test or try? Is it possible that it wouldn't boot up if I got a faulty digitizer and home button?

Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe

1 Antwoord

Gekozen oplossing

Well,you've done a great job researching possible solutions and assuming you applied them properly, everything points towards a logic board issue. You could have damaged the charging circuit, which would impede the startup of the device or you could have nicked or dislodged some components. About the only thing you haven't tried is to inspect the board under magnification to see if there's anything obvious.

At this point, your best bet is to have it looked at by an experienced micro-solderer.

Was dit antwoord nuttig?

Score 3


Boo, I was hoping for some magical answer that I had missed that would fix it. Thank you for your response! Given that they're $240 refurbished I'm guessing I won't save anything to continue pursuing this :(


You can probably have it repaired for much less than that...just call a few shops that do micro-soldering repairs.


Voeg een opmerking toe

Voeg je antwoord toe

glenna zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 1

Afgelopen 7 dagen: 1

Afgelopen 30 dagen: 7

Altijd: 230