Ga door naar hoofdinhoud

The third-generation HTC One smartphone which was first released in March 2015. Its major revisions on the M8 design include the octa-core Snapdragon 810 processor and a 20-megapixel rear camera.

71 Vragen Bekijk alle

HTC One M9 in weird boot loop

I have an HTC One M9 that is being super weird. Its stuck in what looks like fastboot mode and reboots every minute or so. big deal. It looks like someone tried flashing a custom recovery and failed. When I go to recovery mode or download mode, I get "failed to boot to X mode".

Figured ok, I'll check things out in ADB. ADB doesn't list it as being seen and I can't send any commands to it. I would write it off right there except that when I run a logcat and reboot the phone, ADB sees the phone disconnect. So the phone is communicating with ADB on some level, ADB just doesn't detect it.

I'm much more comfortable with Samsung boot issues. Anyone know anything about HTC?

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 1
6 opmerkingen

Rip HTC one m9


Not rip quite yet. Firmware most likely needs reflashing because I unbricked an m9 before.


How do I flash the thing?


It's a bit complicated you need to use and to push the update file. When I get home I'll give you the steps. Its like copying an file to sd card. The problem is that the model number and other id needs to match.


yea...tried adb push but adb doesn't see the phone


1 commentaar meer tonen

Voeg een opmerking toe

2 Antwoorden

Gekozen oplossing

Not to sure on flashing HTC like you I'm more familiar with Samsung . This may help though good luck

Was dit antwoord nuttig?

Score 3
Voeg een opmerking toe

I just went through this with my M9 and it looks like the linked Youtube video is down. :/

[For this, I'm assuming the phone is S-On and the bootloader is locked. It also assumes that the eMMC chip hasn't hit it's End-of-Life and died]

The answer starts off with getting the right aosd.img for the phone. Then, with the phone in fastboot mode and connected to the PC:

Type "fastboot flash aosd aosd.img" and press Enter. This will give you back Download Mode. From there, the choices are:

If the bootloader is OK, you can boot the phone into Download Mode and try to re-flash the firmware using the official RUU .exe. [If the bootloader isn't OK, the phone may go into a reboot loop: To break the loop, hold the Power and Volume Up buttons]

If you are unsure of the bootloader, you can try reflashing the phone by putting the RUU .zip file onto a micro SD card and flashing from Download Mode.

The worst case scenarios I've seen so far are:

If the phone cannot be reloaded via the RUU and you're stuck S-On, you can use an XTC2Clip to go S-Off and reflash the firmware.

The eMMC has exceeded it's life cycle and gone completely corrupt and unrecoverable. At that point, the mainboard would need to be replaced or the original board would need to be reworked to put on a new eMMC chip (iirc, a new chip is ~$5. The main cost is having a reball setup and proper jig).

Was dit antwoord nuttig?

Score 1

1 Opmerking:

Just switch off the location and the problem is solved


Voeg een opmerking toe

Voeg je antwoord toe

Josh W zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 5

Afgelopen 30 dagen: 11

Altijd: 4,484