Ga door naar hoofdinhoud

Repair guides and support for weed whackers, also known as string trimmers, weed eaters, edge trimmers or line trimmers.

27 Vragen Bekijk alle

Why does my Echo SRM-225 gas trimmer stall or bog down?

My ECHO SRM-225 starts on cold setting but dies out soon after, sometimes one to three minutes, sometimes just a few seconds. Throttling always makes it bog down and stop. I recently replaced fuel line and filter (Echo 90097 kit) and still, no better. I have been using TRuFuel 50:1 with no problems for months until now. I checked the plug, not dirty at all. I just checked the spark arrestor screen, and it was clean. The one thing I do notice is an accumulation of grease/oil near the exhaust.

Any suggestions would be appreciated.

Thanks in advance

Miguel

Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 3

Commentaar:

I had the same issue, oily exhaust port and bog down/stall on acceleration. I disassembled carb.. cleaned, (I thought). Cleaned exhaust port. Still a no go. Then I removed the gas filter, same problem. Finally I put the intake hose in my mouth and blew and sucked on it. I left fuel filter off. Now she is running without bogging down and idling okay. If I removed the gas filter and blew and sucked on the line first, I would not have to go through disassemling the muffler and carburetor. I sprayed the jets but the clog must have been in the fuel line. I don't know why my exhaust port was so oily and I thought too much fuel was getting through initially, but that was not the case. I did not make any adjustments to the carburetor. My woeful tale turned to glee and relief, Thanks for your time.

Billy. I own my own lawn service. Thanks for your guidance.

door

It was the cap for me and wasn't getting the full power and oil leaked so I replaced the carb for $15 Amazon and cap, runs like new.

door

Don't use gasoline containing ethanol, it plugs carburetor jets.

door

Een opmerking toevoegen

4 Antwoorden

Gekozen oplossing

elgitano, 4 common things are gas cap venting plugged(loosen cap to see if it runs better). 2nd spark arrester screen plugged, remove and clean the muffler and screen and check exhaust port for carbon accumulation, scrape port clean while holding with port position down or use vacuum so debri will not fall in cylinder when cleaning(carbon debri could harm cylinder walls and rings). 3rd is carburetor out of adjustment,(you may have to adjust the carburetor high or low jet screws) to achieve normal running condition.

4th If none of the above seem to help chances are the diaphragms in carb. need replaced/ rebuild and clean carb. Check the attached links,instruction and guides, Good luck.

I hope this helped you out, if so let me know by pressing the helpful button.

https://www.youtube.com/watch?v=U0LJ3gX2...

https://www.youtube.com/watch?v=0wcmc83y...

https://www.youtube.com/watch?v=cGlJB0on...

https://www.youtube.com/watch?v=KOqTguWw...

Was dit antwoord nuttig?

Score 5

Commentaar:

I appreciate the quick reply L Pfaff. I've actually watched all 4 of these videos today, but will review them to see if I may have missed something.

I failed to mention that I had previously pulled the carburetor apart, but it looked quite clean and in order (i did not replace diaphragms though).

Then, I replaced the fuel lines and gas filter, including the primer bulb. I checked the spark arrestor screen (it was clean) though I did not invert to vaccuum out any possible debris. I had also tried to run it with the fuel cap loosened with no luck.

I have one question concerning the high and low jets- honestly, I don't know where they are on this SRM-225.

I will clean/scrape/vaccuum exhaust port and check diaphragms more closely, and if I can find adjustment screws for jets, I will try them as well.

Definitely very helpful and I appreciate the detailed answers, L Pfaff.

I will be back on to let you know how things are progressing and mention the solution.

Thanks again!

door

elgitano, did you try a new spark plug in case it is fouled,

Echo Zama Carburetor hidden Hi jet screw, link below.

https://www.youtube.com/watch?v=mmbZ5Arp...

door

I did try a new one with no success, but this last link you sent gives me hope!

I will try this out tomorrow morning.

Thanks again!

door

Carburetors on these things are notoriously finicky. It's unlikely the diaphragm needs to be replaced, but it is likely that one of the tiny little passages is clogged. Use a can of spray carb cleaner to make sure all the passages are clean. Inside the main metal part of the carb you'll see a number of tiny holes on the sides, make sure all of them are unclogged (liquid should come out of them when you spray into a corresponding hole in the carb). I know this sounds a bit vague, but just take the carb completely apart and spray the cleaner into every hole / passage. Sometimes this needs to be repeated several times to get it completely cleaned out. Just because it looks clean, doesn't mean it is. These passages are so incredibly small, it's impossible to tell by looking if they are clean or not. Let me know if this doesn't make sense.

door

Makes perfect sense. I've done this many times with the mower carb but had never really piddled with gas trimmer engines before. I had a corded trimmer for so long, and this ECHO is a relatively recent addition.

All in all, in my limited garden power tools experience, I like the ECHO trimmer despite the current troubles.

I will definitely do what you have detailed, including the removal and cleaning of the hidden jet.

Your answers are anything but vague. I love detailed answers.

Thanks yet again.

door

7 commentaren meer tonen

Een opmerking toevoegen

My lawn mower was doing this. I bought new gas and mixed in some Seafoam gas treatment. I drained the tank and put in the new gas / Seafoam mix. Mower immediately started running like new and it still is running like new a year later.

https://seafoamsales.com/small-engines/

Was dit antwoord nuttig?

Score 0

Commentaar:

This spring I bought some new gas and added 10 yr old Castrol Super Oil. The Echo would only idle and would die with any throttle. Dumped it all. Got new gas, added Lucas semi synthetic 2 cycle oil. Bought but did not use Seafoam. The Echo is now running smoothly. It would seem that the old Castrol 2 Stroke oil was the culprit.

door

Een opmerking toevoegen

pull and clean your spark plug with some carb cleaner and a wire brush. had the exact same problem: idling like crap then when I pulled accelerator lever it would conk out almost every time. pulled the spark plug and was black. cleaned it, popped it in and voila! lots of smoke for a bit, but running like a champ.

hope this helps

-Art

Was dit antwoord nuttig?

Score 0
Een opmerking toevoegen

It's 110% the hidden fuel mixture screw. I've messed with a million and 1 of these echo 225’s and it's just out of set. There is a hidden fuel mixture screw right below the primer bulb that usually needs loosened and that almost always fixes the bog down problem with those particular weed eaters…

Was dit antwoord nuttig?

Score 0
Een opmerking toevoegen

Voeg je antwoord toe

elgitano zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 Uren: 57

Afgelopen 7 Dagen: 293

Afgelopen 30 Dagen: 2,470

Altijd: 87,918