1.7 GHz dual-core Intel Processor (Turbo Boost up to 2.6 GHz) with 3 MB shared L3 cache

101 Vragen Bekijk alle

LED display and backlight not working

Block Image

Block Image

After falling a glass of water, I cleaned the entire motherboard with isopropyl alcohol and everything works fine except the backlight and the LED screen, ie pictures but you can see this as having no brightness. Know if there is a fuse you can check.

You can see on the picture that if you approach a light you can see the contents of the screen.

Can anyone give me some help?

Block Image

I can check the fuse as I have a multimeter, on the mosfet I have no idea how to check.

If you can tell me exactly which elements and how you can prove greatly appreciate it.

Thank you very much!

Update

The Serial Number is XXXXXXXXDRV6.

The image of back of the logic board reverse.

Block Image

Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 2

Commentaar:

what are the last three digits of your computers serial number? that will help us to properly identify your computer

door

Een opmerking toevoegen
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12

4 Antwoorden

Gekozen oplossing

Arturo, yes there is a fuse. It is reference designator F9700 and is a 3AMP 32V in a 467package. You will need a multimeter or ohm meter to check it for continuity. Also check the accompanying Mosfet. Any logic board repair will require special tools and great skills. If you can post an image of your logic board with your question, we can point out the parts to check. Hope this helps, good luck.

Update

F9700 is the fuse and Q9706 the power Mosfet FDC638APZ, Q9707 is a SSM6N15FEAPE

Block Image

Block Image

You need to check the voltage on the contacts. this is not easy and if your probes touch other contacts, you will cause further damage. You should get 12.4 Volts on those

further update

Here is the location of the LP8550 LED driver

Block Image

Was dit antwoord nuttig?

Score 5

Commentaar:

Ready the image :)

door

Apparently the fuse is fine (I get continuity), how could check the mosfet?

Thanks

door

Bad news.... :(

The fuse and the mosfet are OK (apparently), I check with the huntron tools and the mosfet FDC638APZ is fine but no power.

Could you tell me how this is powered mosfet to try check where the power failure??

In the scheme two resistance and two mosfets appear, but I can not find them.

The serial number finish in RV6

Thanks!

door

double check your serial number. RV6 does not give me any return. Despite the schematic, I only show one of the mosfet on the logic board. I updated the original image with the location.

door

Arturo, since you seem to have access to some great tolls, have you checked the LED driver LP8550 yet? It is on the underside of your board.

door

2 commentaren meer tonen

Een opmerking toevoegen

Hello,

I'm having similar problem, i'm getting 7.2V at the fuse, but based on the schematic, i should be getting about 12v. Is this correct? I'm also getting about 3v at the backlight enable. Would you have any suggestions as to what might be pulling my voltage down and also what is delivering the 12v power? Thanks.

Was dit antwoord nuttig?

Score 0
Een opmerking toevoegen

i'm having the same problem. fuse has continuity and puts about 8volt. Would this typically be a driver problem or is it the mosfet?

Was dit antwoord nuttig?

Score 0
Een opmerking toevoegen

did it started working i am also having the similar problem the backlight and led is very dim ..everything is been running fine ..i haven taken a service technician she said the motherboard may have been damaged ....is it true it related to the motherboard problems

Was dit antwoord nuttig?

Score 0
Een opmerking toevoegen

Voeg je antwoord toe

Arturo Blanco zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 Uren: 1

Afgelopen 7 Dagen: 9

Afgelopen 30 Dagen: 65

Altijd: 7,022