Ga door naar hoofdinhoud

Origineel bericht door: Adam Ritchie ,


Hi All,

Same for my iPhone 4S. WiFi upgrade to iOS9.3 from 9.2.1 failed/stalled. I then tried connecting to iTunes as the phone was stuck in recovery mode. It still failed about 2/3 of way through and left me with a phone that was not functional.

After 2 hours (over two days) with Apple Tech on Chat they booked my an appointment at the local Apple store. I was not happy as the phone worked perfectly until this upgrade!

Given error 29 is related to the battery or battery connection (by all accounts). The new battery (non Apple) which I installed 3 weeks ago and replaced with an original Apple battery. I also scrubbed the battery connector terminal on the motherboard with a soft toothbrush and rubbing alcohol.

I reconnected the phone to iTunes (old battery) and the upgrade was able to complete. I then replaced the old battery with the new non genuine one I had removed earlier and the phone is working fine.

I don't believe my new battery was faulty nor was there a hardware issue as such, but possibly the iOS9.3 is sensitive to non genuine parts in an old phone!

Good luck if you come across a similar problem as this may help you.

Admiral Adama