Ga door naar hoofdinhoud

A nano-computer is a computer with a size smaller than a micro-computer.

37 Vragen Bekijk alle

What is this device?

Have this little box which I am assuming is a small computer, however I am having trouble identifying it.

I tried connecting it to an external monitor to no avail - it showed no output.



Added Pictures:

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 1
6 opmerkingen

Hi @computerashes

You may have to open it up and check if there's any info printed on the board, that may give a clue as to what it is and perhaps even a model number.

Does it turn on at all, even though there's no display?

Have you tried connecting a set of speakers to the green audio port to check if there's any audio if it does turn on - startup sound perhaps?


@jayeff - Although a startup sound is a good place to start, If it's running windows, It's quite unlikely.



Just covering all possibilities.



@jayeff - Okie dokie, I was just mentioning it was kinda unlikely.


@jayeff I have added pictures of the interior.

It does appear to turn on as the indicator light activates and I can hear some light noise from the inside, as well as it lighting up the keyboard and mouse that I plugged into it however there is no display out.

I have tried connecting speakers to it, sadly no sound though.


1 commentaar meer tonen

Voeg een opmerking toe

2 Antwoorden

Gekozen oplossing


All good.

FYI the device is an Intel D2700DC Apologies if you knew this after opening it up.

If you need drivers/BIOS updates etc then unfortunately according to Intel:

"Device drivers for Intel Desktop Board are no longer available on Intel Download Center after September 13, 2019. BIOS updates are no longer available after November 22, 2019."

You may have to try 3rd party suppliers

Was dit antwoord nuttig?

Score 2

2 opmerkingen:

@jayeff Thanks for that!

luckily it doesn't appear as if it requires any driver updates :)



Here's the manual for the motherboard that may help.

FYI if it seems a bit slow using Windows due to 4GB ram limitation and an Atom CPU, try using Linux Mint (or any other Linux OS version that doesn't require much ram)

I resurrected an old Samsung netbook with a 2GB ram limit doing this and it works fine.

Just a thought



Voeg een opmerking toe
Het nuttigste antwoord

Could be a Intel NUC,

If It doesn't work, You could open it up and see if there are any markings inside.

Was dit antwoord nuttig?

Score 2

2 opmerkingen:

@beanman56 fixed.

It appears the problem was that it had a hidden security USB preventing the thing from booting.


Voeg een opmerking toe

Voeg je antwoord toe

Computer Ashes zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 0

Afgelopen 30 dagen: 0

Altijd: 68