Ga door naar hoofdinhoud

Repair and disassembly guides for electronic keyboards.

215 Vragen Bekijk alle

No power to Keyboard Whatsoever

Yamaha PSR EW 300

it doesnt get power from the A/C power Block or from batteries. I have no clue why nor how to fix it. I've looked inside of it and nothing seems bad. Infact it is untouched until now. Can someone help?

Update (03/20/23)

Block Image

Block Image

Block Image

Block Image

Block Image

Here are the two main boards that are of concern. The A/C power adapter does work. I have a multimeter but im not sure where to check connections with it or really just how to work the magic, i mainly need help to find the bad board so i can replace it.

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 1
3 opmerkingen

@unhandyocean Do you have a multimeter?

door

Can you upload photos please?

door

@andrewsawesome I do have a mutimeter, but i am no electrician.

door

Voeg een opmerking toe

1 Antwoord

Gekozen oplossing

Hi

If all seems good in the inside I would keep a eye out for bulging capacitors(tall cylinders on the board)

I would also check the on/off button/switch by putting the multimeter into continuity mode(looks a bit like this (c•

To test the switch put the probes on some of the pins of the switch and turn it on and off until you get a reaction of of some pins(usually a beep on the multimeter)

You will need to do this for all pins on the switch

I would also look out for corrosion across connections

Hopefully this helps

Any questions please ask

Thanks:-)

Was dit antwoord nuttig?

Score 1

2 opmerkingen:

I've checked or corrosion and there doesn't seem to be any type of corrosion on the boards or connections. Right now of a bit of testing everything had connection. I even plugged up the board and tested the wire ribbon cable from and to the board and they had a connection. The power board does seem to get power. But for some reason the main board isn't getting that power after the cables which could be why even though the power board is getting power, nothing is turning on because the main board is the middle connection to receiving and giving power to the rest of the electronics, yet the main board is not giving the power to the rest of itself. Is there anything else i can do?

door

@unhandyocean

I would check for heat…if you can find out if there’s excess heat being emitted that may point you towards the culprit

door

Voeg een opmerking toe

Voeg je antwoord toe

Tanner zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 4

Afgelopen 7 dagen: 9

Afgelopen 30 dagen: 27

Altijd: 178