Ga door naar hoofdinhoud

Released September 16, 2016. Models A1661, A1784, and A1785. Available in 32, 128, or 256 GB configurations in Rose gold, gold, silver, black, jet black, and (Product)Red.

1364 Vragen Bekijk alle

Will I get an on and off logo if taptic engine cable is broken?

I replace the battery and accidentally break the taptic engine cable. Will that be the cause of Apple logo just turning on and off?

Update (09/16/2022)

I tried putting back the old battery and still showing the same problem, tried reseating all.the cable i took.before and same.thing happen. I tried repair recovery same thing, haven't done the full recovery or dfu reset.

Update (09/17/2022)

Seems there's a hope in unplugging the front camera and it dhows press home button to recover, but my home button is not responding. Is there a connection between home button and the damaged taptic engine?

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 1
2 opmerkingen

With just the update and unplugging the front camera the phone is trying to boot but I got stuck in press home button to recover but the problem is my home button not working too. I replace my Taptic Engine because cable was damaged and do the update still the same boot loop happens . With the front camera disconnected after the update it shows press home button to recover which is the same as before. I ask my son if it’s okay to wipe out the games he has on the phone to do the restore option and of course it’s a yes. With everything connected I’m still getting the boot loop and with the front camera disconnected that’s the time the phone boots normally. There’s a tutorial too in you tube when your home button is not working. My sons phone is now working and my next thing to do there is to replace the home button and front camera cable. Hope this helps.


@daddybuddy I am posting an edited/updated response to your question, I just tend to put everything in my main answer for better visibility to future people who may have this issue. So I wanted to make sure you get notified of that.


Voeg een opmerking toe

3 Antwoorden

Het nuttigste antwoord

It's pretty doubtful the Taptic Engine would cause this issue, the Taptic Engine is not required to be connected for an iPhone 7 Plus to boot properly. If you're getting this sort of behavior after a battery replacement, I'd be more likely to think that the new battery is faulty, or some damage around the battery connector may have been done. Could also be the front facing camera assembly. Retrace your steps, see if anything looks out of place.

There's a pretty extensive page on this sort of "boot loop" issue, but iPhone 7s in particular just have a tendency to bootloop. For a lot of reasons.

UPDATE: 9/30/2022

I am glad to hear you’re making progress. But in regard to your home button issue. Before you replace, two things to be aware of.

  1. Before replacing the home button. Be sure that there is no damage to the outer cable coming from your display. This cable is responsible for home button and is commonly torn during screen removal (because it’s easy to do). If it’s damaged, what you actually need is to replace the display.
  2. If you determine the home button cable coming from the screen is intact, be aware that replacing the home button will require making sure to get one which restores home button function. Many replacement parts will say in the description “for cosmetic purposes only” which means it looks pretty, but don’t fix the button’s function.
iPhone 7/8/SE 2020 Replacement Home Button Afbeelding


iPhone 7/8/SE 2020 Replacement Home Button


Was dit antwoord nuttig?

Score 3
Voeg een opmerking toe

Hi Nielson,

My wife's iPhone 7 plus went into a boot loop like yours spontaneously, and it turned out the be the front camera.

Try unplugging the front camera and power on the phone (disconnect the battery first). If it comes up, buy a new one and replace it.

iPhone 7 Plus Front Camera and Sensor Cable - iFixit Store

iPhone 7 Plus Front Camera and Sensor Cable Afbeelding


iPhone 7 Plus Front Camera and Sensor Cable


Was dit antwoord nuttig?

Score 2
Voeg een opmerking toe

It should boot fine without the Taptic Engine iirc. I would check for damage around the battery connected as it is common for that to get messed up due to poor handling. Have you tried booting with the old battery?

Was dit antwoord nuttig?

Score 1
Voeg een opmerking toe

Voeg je antwoord toe

Nielson Meracap zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 9

Afgelopen 30 dagen: 44

Altijd: 1,030