Ga door naar hoofdinhoud

Support for Android phones by Ulefone.

51 Vragen Bekijk alle

Root gone Boot Loop

I got a Ulefone Armor 11 5G and was trying to root the phone. In the process I overrode the recovery mode to use TWRP and deleted the OS. Eventually, on one of the restarts, I was no longer able to fastboot through the PC and the phone does not stop boot looping. I have been reading forums and looking at videos for like 4 hours now and I literally don't know what to do anymore.

1) I tried every combination I can think of Volume Up + Power, Volume Down + Power, All 3 buttons, changing which button I press first and letting go of the Power button when then Ulefone pops up. I basically don't know what other combination I can do to enter recovery mode. I assume TWRP is still in there since it was on the phone before I restarted directly from the phone.

2) I can't do anything with my computer since it keeps booting the phone and the computer can't recognize the device. Constant USB sounds of it detecting the device then sounding like it's disconnecting after like 2 seconds. I have the rom for the phone on my computer but can't really do anything with that right now...

3) I tried opening the phone to remove the battery but can't for the life of me open the phone. At this point I can only break it to open it.

It's been power cycling for 2 hours now. Is there any other way I can get into recovery mode and stop it from power cycling?

For reference, some of the resources I was using when I was trying to use TWRP / Magisk to start:

TDRL: If I could just even figure out how to enter Recovery Mode… I will be happy ;-;

From: Sad Desperate Hooman

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe

1 Antwoord

Gekozen oplossing

So I was able to save the phone after letting the battery die. This is what I wrote on this forum:

Well since this post, I just basically let my phone battery die. With a clear mind, and some help from here ( I was able to save the phone (yay!).

I got the ROM and MPD from here: which lead me to their drive for Ulefone Armor 11 5G here:
1) Download ROM, SP_MDT_AFterSale_20.32.rar and PDF (RAR and PDF in the "Upgrade tools and USB driver" folder)
2) Follow the steps on the PDF which basically said to scan the port, add the scatter file then start the update. (Read full PDF before trying it)

Hopefully if anyone is frustrated out there, this helps. (I know I was not thinking rationally... lol)

PS: The drive said it might brick your phone with Android 11 but mine worked with Android 11. No issues. So good luck!

Was dit antwoord nuttig?

Score 1

2 opmerkingen:

Had basically the same problem and solution with my Armor 9. Orange-state and boot-loop after unsuccessful attempt to flash a new boot image for rooting purposes. Got the software and guide from manufacturer's website and followed the instructions. Phone's back to a normal state again.

Thanks for the post, was helpful to know someone was successful with this procedure!


Hi, my Ulefone Armor x10Pro shut down after taking a screenshot and has since entered bootloop.

When pressing ON wit volume up also displays a Boot mode selection menu with only 3 options:

Recovery Mode


Normal Boot

Selecting any of the three options (selecting scroll with volume up and conferming ok with volume down) does not change anything, the phone restarts continuously.

Can you help me???


Voeg een opmerking toe

Voeg je antwoord toe

Dum Dum zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 3

Afgelopen 7 dagen: 33

Afgelopen 30 dagen: 126

Altijd: 2,173