Ga door naar hoofdinhoud

Refrigerator freezer not cooling

My side by side refrigerator is not cooling. The evaporator fan and condenser fans are both running. Air is blowing in freezer. Checked the overload start relay on side of condenser. It's fine and condenser is running and not hot. Everything is running as it should but not cold. Any advise on what my issue could be?

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe

1 Antwoord

What about the compressor? Are you sure the compressor is running? If it is, then either you've lost your refrigerant charge, or there's an internal failure in the compressor. Make sure it is running and check the amperage compared to what it could be at (refer to compressor or unit data tag for amperage. Looking for RLA or FLA)

Was dit antwoord nuttig?

Score 0

3 opmerkingen:

It's definitely running. No clicking sounds nor is it hot. I'll have to check amperage on compressor. I gave this fridge to my daughter so she could have a second fridge out in her garage. It had stopped cooling a while back and just needed cleaning. But now stopped cooling again. It's clean, both fans working as should, compressor is running without any clicking, not hot as it should. Could it be thermostat?

door

Another thing. I did remove the starter relay on compressor. There was a slight rattle when shook. Is that normal. I thought a sure sign it was bad would be a clicking sound at compressor trying to kick on and compressor being hot. Neither were present. Compressor was running fine.

door

@jamann if you checked and for sure the compressor is running, then the start components aren't the issue. As for the thermostat, it sounds like it is sending the call for cooling, as it should, but the system lacks the ability to answer that call. It could be lack of refrigerant, or an internal failure in the compressor. Checking the amps will tell us more. If the amps it is drawing are but a fraction of what it says the rla are supposed to be... thats a good indication that there's an internal failure on the compressor. If it is showing maybe half the rla then the issue could be the refrigerant has leaked out, and Schrader valves will need to be used to check pressures.

door

Voeg een opmerking toe

Voeg je antwoord toe

John Amann zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 1

Afgelopen 30 dagen: 14

Altijd: 149