Ga door naar hoofdinhoud

The HP OMEN (model number 15-ax280nd) is a personal computer released by Hewlett-Packard (HP). This model was released in 2016.

4 Vragen Bekijk alle

USB port on one side not working -RESOLVED

I have a hp omen 15 ce00x and I took off the back cover and disconnected the battery and screws holding down the fans i lost one of these screws in the case i couldn't shake it out but after I took the fan out entirely it came out. After this I reassembled the laptop and now 2 out of my 3 ports aren't working I have tried uninstalling the devises and restarting and scanning for hardware and checking for blockage and none of this has worked. It is connected to my motherboard by a white film which goes underneath the fan housing. I have no clue on what the fix might be if anyone could help thank you very much.

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe

1 Antwoord

Het nuttigste antwoord

Hi @ryanarkell ,

Just verifying that you found and removed the lost screw before reconnecting the battery to the motherboard?

Since you say that you can uninstall the USB devices, this means that they’re showing up OK in Device Manager i.e. shown as this “device is working properly” in Device Manager > Universal Serial Bus Controllers > USB Root Hub > right click on Properties > General Tab > Device Status box, (check all Root Hubs), is this correct?

If not, then there may be a problem with the USB controllers on the motherboard.

If so, plug in a USB mouse or mobile phone and check if there is power coming from the USB ports i.e mouse laser lens light turns on or the phone starts to charge.

If there is no power present then, first check that the power to the USB ports has not been turned off. Go to Device Manager > Universal Serial Bus Controllers > USB Root Hub > right click on Properties > Power Management tab > uncheck “Allow the computer to turn off this device to save power” > OK. (check all Root Hubs), You may have to restart the laptop for the change to come into effect, not 100% sure whether you have to or not.

If it was already unchecked then here’s the maintenance and service guide for the laptop, taken from this webpage.

Go to p.51 to view the necessary pre-requisite steps and then the procedure to remove the USB board.

This shows where the ribbon cable from the USB board connects into the motherboard. Check that it is securely connected at both ends.

Update (07/25/2020)

@ryanarkell

If they're all appearing OK in Device Manager it's starting to look like a hardware problem with the USB connectors or their connection to the motherboard.

Time to open the laptop and take a look at the ribbon cable. It could still be a problem with the +5V USB power supply on the motherboard, but one step at a time.

Having the battery disconnected before should have prevented any electrical problems from occurring during what you were doing, so I'm thinking it's looking like something "mechanical".

Was dit antwoord nuttig?

Score 1

Commentaar:

@jayeff I did get the screw out before I plugged in the battery didn't want to short out my laptop or destroy a fan. I haven't tried these yet thank you i did try plugging in my razer mouse yesterday and the green light never came on i also tried my laptop cooling stand and xbox controller. I will have a look right this second.

door

@jayeff I have checked the devices and they say they are all working properly on the general tab and the power save has been turned off and re booted and it still does not work. In the events tabs I can see device not migrated or device not started and device installed if this means anything?

door

also when I rebooted it I did get a black screen with something about cmos and bios I didn't really read but I'm sure it changed the bios and other setting because the time on my laptop changed could this also be an issue? @jaweff

door

@ryanarkell

It could well be.

Look at the motherboard image on p.52 of the manual I linked.

You can see the CMOS battery (or what looks like a coin cell battery with leads attached) is plugged in directly above where the USB ribbon cable is connected on the motherboard.

Too coincidental I'm thinking.

The CMOS battery maintains the BIOS settings when the laptop is powered off. This doesn't mean when the main battery has been physically disconnected, just when the laptop has been turned off.

if the battery is low, flat (or maybe disconnected?) then the BIOS will revert to factory default settings (including date and time, usually back to when it was first built) and you will get a message about restoring any settings that you may have altered to the BIOS to suit whatever you wanted. Most people don't touch the BIOS settings because normally you don't have to.

If you have a Voltmeter, check the CMOS battery voltage. It should be +3V DC. If it is <2.6V DC replace it.

door

@jayeff I don't have a voltmeter sadly otherwise can I revert the bios or change a setting in the bios to resolve this issue. Because it sounds like replacing the ports won't be any better

door

4 commentaren meer tonen

Voeg een opmerking toe

Voeg je antwoord toe

ryan arkell zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 4

Afgelopen 7 dagen: 15

Afgelopen 30 dagen: 89

Altijd: 1,247