Ga door naar hoofdinhoud

Released September 25, 2015. Model A1688/A1633. Repair of this device is similar to previous generations, requiring screwdrivers and prying tools. Available as GSM or CDMA / 16, 32, 64, or 128 GB / Silver, Gold, Space Gray, or Rose Gold options.

2563 Vragen Bekijk alle

Charging problem with battery

Hey.

So i have a strange case going which i have been working on for a few weeks now.

A customer came in with he’s 6S because the phone was dead and not charging at all. I testet this with a USB voltage measure unit and confirmed that the phone does not take any charge what so ever.

Naturally i suspected the battery and replaced it. The phone was working fine and was charging like normal. Then the customer comes back with the same problem. I tried charging it while using the USB voltage measure unit and it said 0.00V. So i took the battery out and measured it to 3.26V. The phone needs 3.8V to start but not to charge. I placed the battery on a charging plate (activation plate). I had it there until the battery reached 4.05V and then put it back in the phone. Again phone turned on and received charging fine. I charged the phone to 100% and left it on without charger over night.

I came back the day after and the phone was off and again didn’t receive any charging. So i checked the battery voltage again and measured it to 3.03V. I put the battery back on charging plate again and charged it to 4.05V. I put the battery back into the phone, the phone turns on and receives charging just fine.

I have tried this with 4 different batteries from different suppliers including the original one. The result is the same every time. I now suspect the Power Management IC.

Anyone out there experience this?

Anyone knows how to fix it or what to do?

Is there something else i can test?

Thanks in advance for all answers!

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe

2 Antwoorden

Gekozen oplossing

It has nothing to do with the power management IC. Is it drawing any current before prompt to boot? If so how much? You will need a power supply and or multimeter for us to help you.

If you haven’t got a DCPS then tell us what the diode measurements are on VCC_MAIN (red probe on ground) We can go from there.

Was dit antwoord nuttig?

Score 1

Commentaar:

Thank you for you answer.

I’ve checked using the DCPS and here is what i,m getting:

Before boot 0.4A.

While booting 0.8A

After boot with screen on, between 0.65A to 1.65A.

After boot with screen off, between 0.35A to 0.4A.

door

You have a partial short on VCC_MAIN or BATT_VCC Unlike a full short these can be tricky to find as they might not put out enough heat to track down.

Check your BATT_VCC line first if that is alright I would inject 4V into VCC_MAIN with some freeze spray and see if you can find the short. Or use a thermal cam.

If the phone has not been water damaged I have a hunch it might be Tigris or the charging mosfet Q2300. I would remove Q2300 and test VCC_MAIN with a multimeter and see if the short has gone. Compare the readings with a known good board. Remember when short finding unless you inject the voltage into VCC_MAIN the mosfet will heat up and you might get trolled by it. Do a really good visual exam first; something might pock its head out.

door

Voeg een opmerking toe

This actually doesn’t sound like a battery issue. The device has a short on the mother board of some kind. This short is causing the battery to drain and discharge past a operating voltage. Once it gets too low the battery won’t charge. Gonna require motherboard repair.

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Voeg je antwoord toe

Total Repairs AS zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 0

Afgelopen 30 dagen: 4

Altijd: 96