Ga door naar hoofdinhoud

An Acer Aspire 5100 Laptop with a 15.4" inch display.

36 Vragen Bekijk alle

Acer A515-43-R19L will not boot, no LEDs showing, no fan

Note that the device is wrong, this is an Acer A515-43-R19L not the one listed. This is the version with an AMD CPU.

After installing Linux (Linux Mint 19.1) on the computer (unknown if coincidental or not) it worked fine for a while, but then one morning I got up and the computer would not boot . There are no power LEDs on the computer that are lit up, pressing the battery reset button does not resolve the issue. I have opened up the laptop and have tried:

  • Removing the cable to the battery and power adapter on the computer
  • Re-seating the RAM sticks
  • Ensuring that the barrel plug is plugged in correctly to the motherboard
  • Unplugging the real time clock (CMOS battery) cable for a couple of minutes then plugging it back in

The motherboard looks normal, there was no smell of burning plastic, the laptop was not hot to the touch, nor was the AC adapter. I did not hear that there was any sort of loud “pop” as is common with desktop power failures.

Anything else to check? This wasn’t a super expensive piece of hardware, so I’d like to try to fix it myself rather than send it in for repair (might actually learn something!)

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0

2 opmerkingen:

Coming to you from Linux Mint 19.2 (yes time to upgrade once you get it working again). Have you tried battery out and on charger to boot? If nothing that way then you will need to grab a multimeter and start doing some voltage checks on the charger and battery. If the charger has good voltage, but the battery doesn't then charging circuitry inside the computer is suspect. Same goes if the computer boots from just the charger being connected (with respect to the battery). If charger is ok and battery seems to be OK, then time to open up the laptop itself and do a visual inspection for damage/loose components, bulging capacitors, cold/cracked solder joints plus voltage/continuity testing. There may also be some type of fuse(s).

PS I've run Linux/Ubuntu/Linux Mint on all the computers I have owned and have never had one go down due to it generating a situation where it destroyed components. :-)


Yes -- I've opened up the computer and removed the cable for the battery (its an internal battery) . Nothing that I can see damaged/loose

I don't have a voltage tester, what do the fuses look like?

Both the charger and battery seem good for prior testing

Fuses seem like a good choice, is there anything that I can do to "reset" the motherboard's power management?


Voeg een opmerking toe

1 Antwoord

The problem you're going to have is that once you've eliminated the easy stuff, you're getting into the territory of something being wrong with the board itself. If something shorted out on the board, you're going to have to either invest in some equipment that will cost more than the laptop to fix it, or pay someone close to what the laptop was worth to possibly fix it. Unless you're emotionally attached to this particular piece of hardware, you unfortunately might be out of luck on a quick fix.

Was dit antwoord nuttig?

Score 0

1 Opmerking:

Have you tried replacing the CMOS battery, as when it is going down, and is completely flat it will display symptoms, such as no power, wrong date and time. This means it is time to replace said battery by taking the laptop apart and replacing the CMOS battery.


Voeg een opmerking toe

Voeg je antwoord toe

Generic_Lad zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 4

Afgelopen 30 dagen: 29

Altijd: 1,326