Ga door naar hoofdinhoud

The Vectrex is a vector based video game console that was developed by Western Technologies/Smith Engineering in 1982.

9 Vragen Bekijk alle

No display image in the vectrex

My vectrex has no image displayed on the screen after replacing two chips in the logic board with the same type. The filament of the tube does not light up. I measured the filament for continuity and it is ok but no voltage on it. It worked before I replaced these chips. Is there any way that the logic board sends commands to light up the filament? I do not think so.

However, I do not hear any sound when powering up the vectrex,shouldn’t I regardless of the screen working or not?

Please help

Update (03/01/2019)

Only 6,7 and 8 pins at the output transrofmer have 12v on them. These are in the primary. The secondaries have no voltage. Probably a blown HV transformer?

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe

1 Antwoord

Het nuttigste antwoord

@neazoi sure it could be the transformer but I would consider other possibilities first. I wonder why and which IC you’ve changed. If it worked before you changed the IC’s it could be possible that hose are the reasons for that (EEPROM issue etc.). Double check things against the service manual Vectrex_service_manual.pdf

Was dit antwoord nuttig?

Score 2
Voeg een opmerking toe

Voeg je antwoord toe

Kostas zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 1

Afgelopen 7 dagen: 1

Afgelopen 30 dagen: 1

Altijd: 95