Ga door naar hoofdinhoud

Repair guides and support for Ematic tablets.

99 Vragen Bekijk alle

My ematic tablet is not working

Hi. I bought this tablet a few days ago and it stays stuck on the screen logo. Now when I turned it off again and pressed the power button and the volume buttons it took me to the recovery screen but I also get the Android man laying down saying no command(separately). When I went back to the recovery screen I tapped the recovery system to reboot and I pressed the power button. It went off and came back on but it is still stuck on logo screen. I really like this tablet so please help or any suggestions. Thank you

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 1
1 Opmerking

I received a tablet for Christmas the tablet never came on I tried charging it never turned on the customer service number is not working can’t get in touch with no one

door

Voeg een opmerking toe

1 Antwoord

Gekozen oplossing

Hi,

What is the model number of the tablet?

Have you tried pressing the reset button for about 5-10 seconds, to see if this resets the tablet back to normal?

It is found on the back of a lot of Ematic android tablets

You will need a pin or opened paperclip to operate the button as it is recessed in a hole in the back cover.

Do not confuse the hole with the microphone inlet hole. You may damage the microphone if you shove a pin in there.

Check the tablet’s layout description in the User Guide that should have come with the tablet to help verify the reset button’s location, (if it has one that is).

Was dit antwoord nuttig?

Score 1

8 opmerkingen:

I am having the exact same problem except mine has no reset button . What can I do?

door

I am having same issue

door

I received a Ematic tablet for CHRISTmas and it won't allow me to download from the play store. Error 403 not certified(???)

How does one get certified? Want to throw it out the window already!lol

Ty4 in advance 4any response to this.

MerryCHRISTmas& HappyNewYear

door

@Theresa Griffith

Assuming that you can get online OK try updating the Play Store app and check if that resolves the problem.

Launch the Play Store app and then tap on Settings in the app, scroll down to Build Number and tap to enter and follow the prompts.

door

@Theresa Griffith

I had the same problem what i did was that i had to change the time because it was wrong maybe you should try it

door

3 commentaren meer tonen

Voeg een opmerking toe

Voeg je antwoord toe

Karyn Moore zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 3

Afgelopen 7 dagen: 14

Afgelopen 30 dagen: 40

Altijd: 2,582