Ga door naar hoofdinhoud

Electrohome USB charging alarm clock radio with time projection. Identification model number: EAAC475.

6 Vragen Bekijk alle

Why can I no longer set my alarm?

Up until today, my alarm clock worked great, but all of a sudden, the screen came up black. I press the buttons and I can turn on the radio, but with the radio on, no matter how often or how long I press the alarm buttons, it doesn’t respond to set the alarm. I press the button again, and it goes black.

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe

1 Antwoord

Het nuttigste antwoord

Hi @dborlase ,

What happens when you press the Dimmer button with the radio Off, does the display come back on again?

This is from p.18 of the user manual for the clock.

ADJUSTING LED BRIGHTNESS You can adjust the brightness of the LED display making it brighter, dimmer or even turning it OFF when the radio is OFF. There are four dimming options available: HIGH/ MEDIUM/LOW/OFF (Standby). Press the DIMMER button to toggle between the four brightness settings.

Here’s an image to show you the button

Block Image

(click on image to enlarge for better viewing)

if it still doesn’t show a display and allow you to set the time/alarm etc try a power reset and see if that works.

Disconnect the AC power from the clock and also remove the backup battery. (see p.11 of the user guide - take note of the orientation of the battery so that you re-insert it the correct way).

Wait for a minute or so to allow all the power to dissipate from the clock and then re-insert that backup battery and reconnect the power to the clock and check if it now operates OK.

Was dit antwoord nuttig?

Score 2
Voeg een opmerking toe

Voeg je antwoord toe

Deborah Borlase zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 0

Afgelopen 30 dagen: 4

Altijd: 143