Ga door naar hoofdinhoud

Model A1138 / 1440x960 screen resolution

85 Vragen Bekijk alle

Not Charging, Do I Need to Replace the DC-In Board?

Hey there,

The adaptor charging ring recently stopped lighting up when plugged in on my Powerbook G4. It boots and runs just fine from the battery, but I can't recharge it once it runs out! I tried the adaptor on a friends computer and it works just fine.

I took the laptop apart and inspected all of the relevant cables and connectors looking for something loose or disconnected. Nothing was found to be out of place. When I put it back together the adapter was lighting up again and I was back with a working computer for a very happy 24-hour period... until it stopped working again. I tried the same procedure again to no avail.

I read that I may want to try replacing the DC-In board, which ranges from $50-$90 since it includes the sound inputs. That got me thinking, so I plugged in a pair of headphones, booted up my computer, and head the startup chime coming from the headphones! Still not charging though..

I'm curious what else I could do to pin-point the exact problem before I shell out any cash for a part I don't need. If I were to get my hands on a voltmeter could I test the voltage on a specific area to isolate the malfunctioning connection? Or, is there something else along those lines I could try?

Thanks in advance!


Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 1
Voeg een opmerking toe

4 Antwoorden

Gekozen oplossing

It took some fiddling about and in spite of my methodical approach I can't say exactly what the problem or the solution was. My theory is that my previous DC-In board had problems, and somehow made my previous adapter act a little wacky. Replacing the DC-In board and replacing the adapter seems to of done the trick.

I'd like to tell more detail for anyone else finding themselves in my shoes but I'm going to give it a few days of trying it in different situations before I make any definite statements. I just didn't want the suggestions and comments to run rampant with ideas when I seem to have found a solution. Thank you so much to everyone for their invaluable input! I'll update with more info on the problem in the coming days!

Was dit antwoord nuttig?

Score 1

2 opmerkingen:

+ You had a very good approach to the problem. Perhaps if you have a volt meter you could document the voltage at the I/O connection for the next person and post that here.


It might be a bug in the software for the charger? A voltage-virus.

Ho knows..


Voeg een opmerking toe
Het nuttigste antwoord

Wow, this is an interesting case! DC-ins are very strange creatures...I've run across many in iBooks that appear dead or problematic, but once they are disconnected for a while, then re-connected, they work like new. It's as if they hold onto a "bad charge" which affects their behavior until it is allowed to dissipate. The question in this case seems to be, what is causing that "bad charge"?

Here's what I'd do: First, make sure you have a 65-watt AC adapter, since 15" aluminums don't like 45-watt ACs. That could be the problem right there -- 45W adapters often work for a while, but then weird stuff starts happening as they (I assume) are ultimately unable to meet the power requirement. Next, since you mentioned having your DC-in temporarily disconnected made it work temporarily, I'd go in and disconnect it for an hour or overnight, then re-connect it. Next, I would remove your battery, and connect your laptop to AC power, but do it on the other side of the house (on a different circuit). If it works in that condition for a sustained period, you can try either the battery, or plugging into the original power source, to see if it goes bad again. Doing this, step-by-step, hopefully you'll be able to isolate the issue.

If none of this helps, you may be looking at a bad board.

Was dit antwoord nuttig?

Score 5

4 opmerkingen:

Of course, not all DC-ins work "like new" after being disconnected for a period of time -- I was commenting having read that you replaced the DC-in, and that the replacement was suffering the same symptoms. This leads me to suspect that something, whether it be the AC power source, battery, or board, is affecting your DC-ins, and that the DC-ins themselves are probably not bad.


+ Thank you rdklinc your experience helped me understand a few things about this animal. Sometimes they say a picture can say 1000 words. Your words here have painted a picture. At this point, I am not sure if your picture will help Benji or not. But thank you.


Alright, I'm going to do some tip-toeing around this because I don't want to jump the gun and tempt fate: my computer is currently working.

The original adapter seems to be dead now. I'd tested it in other computers and it had worked, but I feel that somewhere along the way my previous DC-In board somehow fried it, or something along those lines because it is no longer functional.

The new adapter, also 65w, now works on my computer. My battery is charging, I can run it with just AC if I take the battery out or just the battery if it's unplugged i.e. a normally functioning laptop.


Benji I moved to have your last comment here as an answer. In essence it is the answer. If my motion gets accepted all you will have to do is accept the answer for others to see. What I need to know is if you tried my last suggestion: 1) Take out you battery and unhook the power cord from the laptop. 2)Press the power on button for 30 seconds. 3)Let the laptop sit for 2 hours. 4)Press the power button for 30 seconds. 5) Plug the power cord back in. 6)Press the power button like normal and see if it will run like that with out the battery. Etc... This suggestion would have gotten rid of the "ghosts" that caused this: My battery charged, I was happy typing away getting ready to finish my projects.. it stopped working. So I'm starting to think my computer somehow is affecting the adapters I'm plugging into them. Does this make sense? I really don't know how else to explain this phenomenon." which was almost your last communication with us. I don't want any credit. I want knowledge to help the next person.


Voeg een opmerking toe

The part you need is 922-6963. You might want to do a web search. Of course the iFixit parts are tested


The only part left is the battery connector. With the AC adapter plugged in, use a multimeter to test the connectors. Here's the part: [gekoppeld product ontbreekt of is uitgeschakeld: IF154-067]

Was dit antwoord nuttig?

Score 2

5 opmerkingen:

Yes, I've actually already got that part no. written down here, but thanks. I am looking for more precise ways of testing the issue to ensure it's the DC-In before I purchase it and go through the install process.


Thanks for the info, but I'm not sure if I understand how that part would help. When the charging ring lights up, my battery gets charge just fine. The problem is that the charger is not lighting up.


Do you mean your only problem is that your light on your AC charger is not coming on and all else is working correctly?


No, I'm referencing the light because that is what I look for to see if it's working. I mean that if I have no battery in my computer, I should be able to plug in the adapter and run it without the battery. I can't currently do this.


I've never seen a Mac that burned out power adapters. I have seen wall plugs do it


Voeg een opmerking toe

Something weird is going on with these Powerbooks and chargers.

My charger works fine most of the time, but occasionally stops charging without me having touched, unplugged or changed anything. My laptop is plugged into the charger 99.9 % of the time, I basically just use the laptop as a desktop. It will run for months on end without any problems and then, one day, unexpectedly, I may notice that the lighted ring on the charger's plug is not on, or, if I missed that, I get a warning that my computer is running on spare battery power, even tough it is still plugged in to mains power. This will then happen every day, usually only once a day, sometimes twice, for a few weeks or a month or so, and then the issue goes away again for a few weeks or months.

The remedy I have found is to unplug the power cord from the charger, leave it for a few minutes, then plug it in again and everything will be fine till the next day. Unplugging the lead form the computer itself does not work, it has to be the mains lead that plugs into the adapter. If I don't wait long enough before plugging it in again, the problem repeats itself straight away, i.e. the charger stops charging after a few minutes.

It does not happen at exactly the same time every time, no apparent connection to hot or cold days, it is not a charger over-heating problem, it's not re-produceable at will - it's just completely baffling! I have two chargers, both do the same thing. I have re-set PRAM, no difference. Tried all sorts of things, no difference.

It is a known problem; I have searched the net for a solution and found others have had the same issue. I have found "remedies" suggested by others, but nothing seems to fix this issue.

Anyway, it's no biggie, just a annoyance, and a mystery I haven't been able to solve. Apple must have put it in the "too hard basket" themselves too, it has been discussed on Apple's web site forum, but no solution there either.

I guess this Powerbook will eventually take this mystery to its grave ...

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Voeg je antwoord toe

Benji Bilheimer zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 6

Afgelopen 30 dagen: 22

Altijd: 4,706