Ga door naar hoofdinhoud

Repair information and guides for the iPhone 6 that was released on September 19, 2014. Model Numbers: A1549, A1586, and A1589

4998 Vragen Bekijk alle

Water Damaged not booting tried lots looping with 70mA draw

Hi I have a water damaged iPhone 6 that has come to me for repair. There was been a previous repair on it but I do not know if it is related. C5202_RF has been replaced and although electrically sound is very messy.

Taking of the shields all is clean except for the speaker IC which is heavily corroded. I have removed this IC and replaced the bad and shorted CAPs around it. It was all on the PP_BAT line....

With bench PSU connected it draws current without being prompted to boot. I then removed the VIB motor IC and now no current draw until prompted to boot. When promoted it draws around 70mA for a few seconds and then goes back to 0mA and continually loops. I have noticed during this cycle that the major lines from the PMIC are all OK but nothing out of the BASEBAND power chip - perhaps too early for that in the boot cycle. VC_MAIN is good at 4v but it does drop to around 3.8v shortly after power up and I am wondering if something is bringing the line down or not causing it to restart continually.

I have replaced Tristar, Tigris and the PM IC (as they all use PP_BATT and that took a big hit) and also the BASEBAND PM IC. Also ultra sonically cleaned PCB - no other visible damage.

Still no difference in the looping every few seconds of 70-80mA

Any ideas? have spent a lot of hours on this one replacing a good 10 components and made some progress.... currently Speaker and VIBE IC's and C5202_RF are all removed everything else in place.....

Help much appreciated and hope this will lead to a good reference for others with this fault.

Update (12/17/2017)

I have not had any responses :-( but I have still been looking for answers so this may help someone with a similar problem. If anyone out there can help or add to my problem I would still be grateful to learn.

70mA according to Jason and Jessa has pointed towards I2C signalling problems. I2C is a standards based signalling protocol explain HERE Basically for each I2C communication line there are a a pair of lines, a clock and data line, and they operate more or less at 1V8. There are three main I2C lines in the iphone 6 and I have tested all of them and they are fine. Here is an extract from the schematic showing the addresses of each Chip on each line, for my problem I think it would have revolved around I2C0 or I2C1 where Tigris / Tristar / PMU live. Common problems are the pull up resistors on this lines or I guess being grounded. As I say for me they are all good.

Block Image

My problem is still that I get 70mA after prompt to boot and this resets itself after a few seconds and continues on it merry cycle. All PMIC voltages look good when VCC_MAIN is up.

I only had a Tigris from a donor board - I have some more coming in and will try a brand new Tigris when I get them and update again.... I also suspect something may be bringing down VCC_MAIN at boot time

but this may be very hard to find.....thanks for reading / contributing.

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 2
Voeg een opmerking toe

1 Antwoord

Gekozen oplossing

Please measure the output voltage on RESET_1V8_L while you are trying to boot it. If it is cycling between 1.8V and 0V, then measure it's resistance to ground and do a diode mode check on the line. Then check R0206/C0201 to insure the line is properly pulled up to 1.8V.

Was dit antwoord nuttig?

Score 5

7 opmerkingen:

Thanks for taking the time to read and reply Minho. I have tried as you suggested. The Line is cycling from 0 to 1V8 but this is in time with VCC_MAIN going up and down. I would expect this as the RESET_1V8_L gets its power from PP1V8. The Diode reading was 0.37 or 96K ohms which looks OK to me. I cannot get to R0206/C0201 without bending the shield but they look OK under the microscope and the correct voltage does get there. Is it worth putting 1V8 on this line permanently with a PSU and see what happens? Thanks once again.


You could try to inject 1.8V into TP2508 or replace R0206 for a lower value. Also if you could test the continuity between the different points between RESET_1V8_L to see if there isn't an internal break amongst the traces. You could also pop off Chestnut or Mesa or Tristar to see if anything affects that line. Lastly, check the Reset Lines on the PMIC to see if anything is amiss. Ultimately, it could be a CPU problem.


Thanks once again for your reply Minho this is great stuff. So I bent back the shield to access R0206/C0201 and they seem fine. I also measured a known booting device and the resistance and diode mode reading were the same (87K/0.37) consistent with the 100k ohm resistor R0206. I have already replaced Tristar but was wondering about Chestnut so popped this off with Mesa and no difference.

I then hooked up TP2508 to 1.8 volts permanently and tried to boot off battery with USB amp meter. Looks like the same cycle, every few seconds the amp meter goes from 480mA (Charging) to zero and again and again. The line always has the 1.8V up so I do not think it is this line causing the reset? All I can say is that all my PMIC voltages drop to zero, just VCC_MAIN remains up.


I do not know how to check the RESET lines on the PMIC, the ones I can see on the schematic do not connect to other components just BGA chips and no PP or TPs.

I think this one is fast going into the "no fix" pile. I do though really appreciate your replies and have learnt a lot from this one.....


Yeah, some of those resets can only be probed with the PMIC removed. Of course, all you can do is check to see if they are shorted...


2 commentaren meer tonen

Voeg een opmerking toe

Voeg je antwoord toe

Nathan zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 0

Afgelopen 30 dagen: 3

Altijd: 2,132