Still stuck on a white screen

So I upgraded to High Sierra, and a few days later I moved my computer to another side of the room. When I came to plug in the external hard drives (photographer, so I have a few), a screen popped up in the top corner saying that ‘too much power used by usb - please remove to retain usb usage’ or something similar, and none of the hard drives were picked up at all. I read that I should shut down, pull the cable out the back for 15 seconds and plug back in. Did that and now I have been trying to get past the white screen of death.

The loading bar loads fully, but after half way it slows down - getting slower and reaching the end and hour or more later. I have left it like that for several hours to see if it would load. It didn’t.

I looked into the problem, tried cmd+r to first-aid hard drive...wasn’t necessary. I also tried resetting PRAM and that did nothing. Reinstalled the High Sierra twice and now have run out of options. I can’t upload or use time machine backups as it won’t recognise the external hard drive.

What I might have done myself is that when I restarted the machine the first time after the usb problem, I didn’t remove the external hard drives though I should have in hindsight. Other than that, I am lost. Please help

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 1

4 opmerkingen:

@mayer fixes this [white screens] pretty often he could help!


? Is it a person or blog? How do I find this? Thanks


Ah got it! Thank you


Hey @mayer, feel free to take credit for this. this is yours.


Voeg een opmerking toe