No backlight + no keyboard backlight implies fuse problem?

I have had display problems, so I changed the backlight fuse on my Macbook Air. After that, there is still no display. The computer works fine otherwise, I can turn it on and hear sounds.

As of now I am wondering whether I soldered wrong, or whether the problem is with the backlight itself.

I also noticed that there is no keyboard backlight. Even if I hit the keyboard backlight keys, it doesn't light up.

I was wondering whether that means that my soldering is wrong, or not. Is the backlight fuse also "protecting" the keyboard backlight ?

EDIT: I did some measurements on the logic board. My interpretation of them is that everything seems fine, except the voltage divider for BKL_EN. For some reason, even though input voltage seems fine, and both resistors have correct resistance, divider output is slightly lower than it should be.

The only weird thing I notice, that could explain this value, is the fact that resistance rises slowly when I measure it. It starts at half the final value, and rises logarithmically for about 30 seconds.

Here are the measurements:

Global values

  • PPBUS_G3H : 8.3V
  • SMC_LID : 3.4 V

Driver output

  • PPVOUT_SW_LCDBKLT : 8.43 V
  • PPVOUT_SW_LCDBKLT_FB (at test point) : 8.4 V
  • PPBUS_SW_LCDBKLT_PWR_SW : 8.46 V
  • PPBUS_SW_BKL (before L9701 inductance) : 8.32 V
  • Output of inductance
    • When measured in DC : 8.32 V
    • When measured in AC : 17.5 V
  • Feedback line connectivity check:
    • By putting multimeter in diode mode, placing red probe on ground, and black probe on PPVOUT_SW_LCDBKLT, multimeter displays 510/512/515
      • A second measurement gave 530

BKL_EN circuit

  • BKL_EN : 2.64 V
  • PPBUS_SW_LCDBKLT_PWR : 8.43 V
    • measured both at test point, and on resistor closest to driver
  • Fuse : 8.43 V
  • Resistors
    • R9731 : 201 kOhms
    • R9715 : 101 kOhms
    • => theoretically BKL_EN should be : 2,72

Other driver inputs

  • PP5V_S0_BKL : 5.17 V
  • PP3V3_S0_BKL_VDDIO : 3.3 V
  • BKL_PWM : 3.34 V
  • LCD_BKL_PWM : 3.34 V

LCD activation circuit

  • PP3V3_SW_LCD : 3.25 V

Other output

  • LED_RETURN_1 : 0V
  • BKL_ISEN_1 : 0V
  • LED_RETURN_2 : 0V
  • BKL_ISEN_2 : 0V
  • LED_RETURN_3 : 0V
  • BKL_ISEN_3 0V
  • LED_RETURN_4 : 0V
  • BKL_ISEN_4 0V
  • LED_RETURN_5 : 0V
  • BKL_ISEN_5 0V
  • LED_RETURN_6 : 0.5 V
  • BKL_ISEN_6 : 0.5V
Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 2
Een opmerking toevoegen
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12

1 Antwoord

Gekozen oplossing

If both the screen and keyboard aren't lighting, the issue will be with the backlight boost circuit (most likely the backlight IC).

You would require a schematic and board view for your particular board to diagnose this (board number etched on board, Google to find the files). You will also need a multimeter to measure the backlight output voltage (to see if this is the issue) and a hot air station (if it is a backlight IC problem, since it is a BGA chip).

Get the files and equipment if you think you can do it, then let us know when you are ready to check this. If you feel it may make the situation worse, it may be best to send it to someone who fixes these on a daily basis.

Was dit antwoord nuttig?

Score 4

Commentaar:

@reecee thanks a lot for the swift reply ! I have tried reading some schematics and finding board views but never really succeeded. I also don't have a hot air station.

Is the backlight boost circuit on the motherboard, or in the display assembly ? Would replacing the whole display assembly solve it ?

I am asking because I was thinking one other way to test this was to plug another display assembly and see if it lights up : http://apple.stackexchange.com/questions...

door

The backlight boost circuit is on the motherboard. You can plug in a new screen assembly to check (sometimes the screen PCB can be burnt and causing the problem), but it's highly likely to be the circuit, unless you spilt liquid onto the screen itself.

door

You would need a hot air station to replace the IC, have you measured the voltage on the fuse yet?

door

What is the history of this MacBook Air? They rarely fail on their own. Was it liquid damaged?

door

@reecee thanks a lot for your answer. I'll check by plugging my Macbook Pro's screen instead, but I am afraid to damage it by doing that, so if I can diagnose in another way, that would be great. I haven't spilt liquid onto the screen, but it is damaged. I arrived to this problem because it wasn't operating well, having flickerings on horizontal lines, sometimes scaling only one third of the screen to the whole size, sometimes not displaying at all. So I opened it up, but made things worse :(

door

31 commentaren meer tonen

Een opmerking toevoegen

Voeg je antwoord toe

John Dupont zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 Uren: 2

Afgelopen 7 Dagen: 18

Afgelopen 30 Dagen: 67

Altijd: 1,214