Ga door naar hoofdinhoud

Repareer je spullen

Recht op reparatie


The Canon PowerShot A470 is a 7.1 megapixel digital point-and-shoot, announced January 2008.

13 Vragen Bekijk alle

Camera no longer connects to my computer to import photos

Camera is not longer recognized by my computer (iPhoto). New pictures on camera are not showing up in iPhoto.

Also camera requests that I reset the date & time every time I turn on the camera.

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe

2 Antwoorden

Gekozen oplossing


First regarding the date and time. You need to replace the date and time battery in the camera. Here are some images on how to do it.

Block Image

Block Image

Regarding your camera download problem, have you tried a different known working USB cable or a different USB port in your computer? Have you upgraded either the computer OS or the iPhoto software recently?

If you have upgraded the OS for your computer, have you got the latest drivers for the camera installed in your computer? Here is a link, select the appropriate OS for your computer,

Downloading and installing the Camera DC software should install the latest drivers available

Hopefully this is of some help.

Was dit antwoord nuttig?

Score 4


The new battery corrected the date/time issue. Thanks so very much!

Regarding the other issue, I downloaded the updated software with no success. Also changed USB ports with no success. iPhoto doesn't even recognize that the camera is plugged in. Do you have any other suggestions? Is it time to get a new camera??


Hi, Visually inspect the USB port in the camera with a magnifying glass and a good light to see if all the pins are still there and are straight and parallel with each other and that there is no dust or lint clogging the port.

If it looks OK try plugging the camera into a different PC (make sure to turn the camera on). With Windows it should identify that there is a new device connected. I do not know anything about how Mac's behave. If nothing happens then the USB controller in the camera or the USB port in the camera is faulty. You did try a different USB cable didn't you? You didn't mentioned it.


Voeg een opmerking toe

Some cameras need to have a "USB Mode" turned on for them to be seen by the computer. With your settings getting reset maybe that did to. Alternatively you could just take the SD card out of the camera and plug it in directly if your Mac has a SD card reader, the newer iMac's and 13" MacBook Air and all MacBook Pro's have it. Or you could buy a SD card to USB adapter like this:

Was dit antwoord nuttig?

Score 1


It is just so odd that as of yesterday the camera connected to iPhoto and today it does not. Frustrating. I just ordered a new cord . . . hopefully that is the solution. Thanks again!


I just found the SD card slot on my computer (who knew?) and it worked PERFECTLY!!!!! Thank you soooooo much for all of your help and patience! ;)


No problem, glad it worked.


Voeg een opmerking toe

Voeg je antwoord toe

dpakler zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 1

Afgelopen 7 dagen: 3

Afgelopen 30 dagen: 40

Altijd: 1,632