Ga door naar hoofdinhoud

My phone is swictched off

my lava iris x1 atom is switched off now it is not opening is it phone fault or battery fault

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 10
9 opmerkingen

my phone was stopped


my phone not turning on


my mobile not getting oned when it is restarted


my mobile shuts randomly


My lava iris battery drop up and down


4 commentaren meer tonen

Voeg een opmerking toe

2 Antwoorden

Gekozen oplossing


When you plug in your charger does the phone show that it is charging?

If so, let it charge for a while, then see if you can start the phone with the charger still connected.

If it does start, shut down and then see if you can fully charge the battery. If it doesn't then the battery is faulty and needs to be replaced.

If the phone does not charge with the charger connected, try another charger.

If it does then your charger is faulty.

If it still doesn't charge with a different charger then the charging circuit in the phone or the battery is faulty

Was dit antwoord nuttig?

Score 4

4 opmerkingen:

My lava iris 405+ is not switch on why? Charger is in good condition and battery also. I hope u answer my question soon plz reply fast


My Lava Iris X8 when connected to charger turns on and gets instantly of and so on is there any solution for this problem


My Lava R1S with Non-changeable Battery is not switching on, a day before i switched it off and next day switched off I charged it, it was charging but when I tried to switch it on but it didn't. Keep trying to switch it on but nothing is happening, then I connected charger but it wasn't charging only charging light works but when I removed charger light was still on.... I even tired different charger from my friends but same issue. Battery is in normal condition

No idea what to do. Please help me out in this matter... Thanks


My Lava R1S

No display for battery charging

No powering on Screen

No vibration

Tried Power + Volumn Up button together for Hard Reset but not working


Voeg een opmerking toe

Hi @ badar.khayam

All I can suggest sis that you open the phone and disconnect the battery for 5 minutes, then reconnect the battery and check if starts OK.

Here's a video that shows how to open the phone. At 4:12 minutes into the video the battery is seen being disconnected (cable on top left of battery.

You don't have to remove the battery, just disconnect it from the systemboard.

Be very careful when working in a phone. Even though the phone is off there is still power at certain points on the board etc. The Power button is not a power isolating button. It merely signals the operating system as to what the user wants to do. Think of the phone as being in an extremely low power state rather than being totally isolated from the power supply.

Try not to touch anything that you don't have to and also do not short out any components with other components by bridging the tool across two etc

Was dit antwoord nuttig?

Score 1
Voeg een opmerking toe

Voeg je antwoord toe

Bramhananda Reddy zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 0

Afgelopen 30 dagen: 18

Altijd: 15,289