Ga door naar hoofdinhoud

HD action camera released October 5, 2014.

79 Vragen Bekijk alle

My Record button and Wifi button are not working

My GoPro Hero 4 Black edition camera turns on and works okay, but the record button on the top and the wifi button on the side do not work. How can I fix these?

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 4
Voeg een opmerking toe

1 Antwoord

Het nuttigste antwoord


Did you pull out the cables between the outer casing and mother boards? More specifically the gold tipped smaller ones?

This is normally the issue.

If you dissemble the GoPro to the point where the mother board it free from the LCD board then you should be able to put this back in place and then put it all back together again (although it's a little tricky) if that's not fixed it then it could be a component part which needs to be replaced.

Was dit antwoord nuttig?

Score 1

6 opmerkingen:

Hi Geoff, I have the same problem which I posted in a question. After replacing the lens the shutter and wifi buttons don't work. Also there is no sound in the video I have made. I did disconnect the motherboard. Which of the wires are responsible for the function of those buttons? There is the small gold ribbon strip (In the red square of the repair guide) which I suspect isn't making contact correctly and another with 3 black wires which clips to the motherboard. Do you know which one connects those buttons and if this could also have to do with the lack of audio? I hope you can help. Thanks in advance.


Hey Greg.

The tiny ribbon that needs to fit (GoPro Hero 4 Black USB Replacement it's step 4 and the ribbon in the red square. )

I had loads of difficulty with this part. What I did was removed the battery compartment and then all the internal components and tested the functions while outside the main housing. That little cable needs to be in perfectly to ensure that the functions work. That cable is responsible for all the button actions and mic. (I think I must have used around 3 days just tying different was of taking it apart and putting it together again and trouble shorting. Hopefully you don't have the same trouble.)


Hey Geoff,

I found found out from a tear down video that that tiny gold ribbon strip IS the culprit. I've taken the MB off the LED screen and lens plate to have access to the other side. As you stated, I am having a very difficult time getting the ribbon back in the slot. It appears to be a ZIF connection like the larger clip on the motherboard. When I tried lifting the tiny white "lever" on the clip, it broke off. The ribbon doesn't seem to want to slide all the way into the slot and is complicated by the angle of the housing it's attached too. Every time it looks like it's somewhat in and I begin to reassemble the rest of the parts, it pulls out...very frustrating. My fear is that if it is a ZIF connector (do you know?), that I've broken it off in the closed position and that's why the cable doesn't want to go in. Does the 2 or 3 mm of the metal end of the ribbon strip have to be all the way inserted? I'm guessing yes. Anyways, thanks so much for your kind response!


Hi Greg

It is very frustrating and that's why it took me so long. In the end I put the camera down for a few weeks and tried again and it then worked. The hardest part is to secure that tiny ribbon. It's rather deceptive but it only needs to go a little way in. Once I had it in a tested it before putting the camera completely back together. Nothing worse that closing up and then finding something doesn't work. Sometimes it was sound issues. Sometimes it was wifi issues.

I guess there is a small amount of luck involved but I hope you get there in the end.


Hi Geoff,

I hear ya. I've now opened and closed the camera several times. This time I used a tiny strip of electrical tape to hold the cable to the connector the Zero Insertion Force is anything but. I seemed to have broken the "latch" and I'm not sure if there is something blocking the entry of the cable. However, I've have had semi-success; I got the shutter/record button working but the wifi and audio are still out so I think I don't have it in there sufficiently (I hope that's it). The most vexing thing is, that it wasn't necessary to undo that cable to change the lens. Thanks for the support!


1 commentaar meer tonen

Voeg een opmerking toe

Voeg je antwoord toe

Joshua Budney zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 3

Afgelopen 30 dagen: 29

Altijd: 2,912