Ga door naar hoofdinhoud

The TI-84 Plus Silver Edition is a graphing calculator released in 2004. It includes a USB port, pre-loaded software, APPS, storage, and a removable front and back case.

32 Vragen Bekijk alle

My buttons won't work

When I turn my calculator on, the calculator will not recognize when I push any of the buttons.

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 7
3 opmerkingen

omg i cant stand this i cant get any answers to nothing everything I do or look up it dosent give me any answers does any one feel up to giving me any answers????


Hi @tayco_queen1305 ,

If people knew what you wanted the answers to, perhaps you might get them.

What is the problem that you are having with your device, (besides getting answers)?

Please include make and model number and any relevant details such as what is or is not happening and what you have tried to do to resolve the problem if anything.

Post your response as a 'New" question in ifixit.

Linking it to a 3 year old post may not draw too many responses.


I had the same problem with my TI-84 plus silver edition. I took it apart and vacuumed it and cleaned it after that it is working fine. Be sure not to touch the circuits with your hand. hold it by the sides.


Voeg een opmerking toe

3 Antwoorden

Gekozen oplossing

unknown, I'd start with some basic trouble shooting. Remove the internal battery for a minute or two. If there are not results with it try to

- check for a stuck key

- reloading the software

- open up the unit and shake it out in case something is blocking the key contacts

- clean the circuit board contacts under the keys with an eraser

After that you are in for deeper testing. you would need a multimeter to check the resistance between the opposite halves of the keypads. For that you would of course remove the membrane. Low resistance between the two halves would indicate that it is shorted somewhere and would be interpreted as a stuck key. Use this guide to get to the keypad.

Was dit antwoord nuttig?

Score 6

4 opmerkingen:

Thanks for the suggestions - under the assumption it was a stuck key I spent a few moments "massaging" the keys, and after a bit, it worked just fine! Hope this helps someone avoid a more intense solution...


I followed these directions and the calculator is now working. My gut instinct was that using the eraser did the trick because none of the keys seemed to be sticking. I am pleased but surprised! Thanks.


Cleaned contacts first with eraser, then went over all the contacts with alchohol to clean them. I checked continuitiy and it seemed to work, and also checked resistance with respect to power. As power was only working button for me. I had around .7 ohms the whole way through every button up to 1.2 ohms. Sprayed all of the components with duster and went over all circuit board lines with qtip and alchohol. It worked. hope it helps someone else!


I have been searching everywhere for the answer. THIS was it! Cleaned the contacts with eraser and alcohol and voila! Works like new!

Thank YOU!


Voeg een opmerking toe

Try pressing and holding the little reset button on the back of the graphing calculator.

My calculator had a blinking cursor but was not responding to any buttons and couldn't turn off (buttons wouldn't respond). After holding down the tiny reset button it reset with all the buttons functioning again.

Easy fix. Hope's this helps someone.

Was dit antwoord nuttig?

Score 3
Voeg een opmerking toe

how do fix Casio HS-8LU

Was dit antwoord nuttig?

Score 0

1 Opmerking:

this should be a new question


Voeg een opmerking toe

Voeg je antwoord toe

unknown zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 74

Afgelopen 7 dagen: 997

Afgelopen 30 dagen: 1,372

Altijd: 68,190