Ga door naar hoofdinhoud

Second generation of iPhone. Model A1241 / 8 or 16 GB capacity / black or white plastic back. Repair is more straightforward than the first iPhone. requires screwdrivers, prying, and suction tools.

1505 Vragen Bekijk alle

Where is cellular antenna connector

Trying to figure out why i have no service. Have tried all the usual, reboot, restore, sim check. Have also replaced the dock connector but still wont work.

Works fine when in a really strong signal area.

Thanks in advance, Chris.

Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 1
Een opmerking toevoegen

9 Antwoorden

Gekozen oplossing

it's the little gold prong on top of motherboard next to battery screws. easily bent when removing motherboard for battery replacements etc.

Was dit antwoord nuttig?

Score 2
Een opmerking toevoegen

Having a very similar issue and realising that the next place to look is the mainboard to antennae connector, it is just below the battery power connector (towards dock) and appears to connect to the metal ring around the glass of the phone and through to the antennae on located on the back of the dock connector.

Anyone is welcome to add more info or correct me!

Oh and someone seems to have done some soldering on my main board and that connector is missing! if anyone knows what that part is, or how I can fix without one...

Was dit antwoord nuttig?

Score 1
Een opmerking toevoegen

Where is the mainboard to antennae connector?

"it's the little gold prong on top of motherboard next to battery screws." (pollytintop)

Can you give me the link to the correct picture? I'm not shure what connector you mean!

Is it the one on the right?

http://guide-images.ifixit.net/igi/vutmf...

Thanks in advance!

Update

I think I know what you mean by "connect to the metal ring around the glass of the phone and through to the antennae on located on the back of the dock connector."

Its next to the "do not remove lable", right?

http://guide-images.ifixit.net/igi/UbuxL...

Was dit antwoord nuttig?

Score 1

Commentaar:

on your first picture you can just see a very small gold pin on top of dock connector... this is the connector from your dock antenna. the other "gold prong" is on the motherboard itself, next to sticker saying do not remove-it makes contact with the silver bezel surrounding the display. sorry but i don't know how to edit your photo to show you exactly what i mean

door

Een opmerking toevoegen

yes, i would like to know that too, since unfortunately there is no repair guide here for loose cellular antenna only for the GPS one, but GPS works fine. i have the same problem since i changed the battery. Seems that i was a little too clumsy but all main connectors (one through six) are fine... i guess.

thanks for helping!

volker

Was dit antwoord nuttig?

Score 0
Een opmerking toevoegen

ah, mine is missing, probably where the last owner did as you said! Do you know where I can find this part, or if there is a work around?

Was dit antwoord nuttig?

Score 0

Commentaar:

i asked this question a few days ago and am still waiting for a reply....think i might just take one off another broken motherboard and resolder. i'm sure the part can be made or bought somewhere

door

Een opmerking toevoegen

I fixed this on my iPhone by taking a short piece of earphone cable (thin and flexible), soldering it to the point on the motherboard where that copper piece used to be, and the other end to the little copper aerial piece on the dock connector (on that image it is the little copper pin to the bottom left of the battery power connectors).

Worked for me :)

Was dit antwoord nuttig?

Score 0
Een opmerking toevoegen

I found a great tutorial on the net. Maybe it will help you!

"How I recovered my iPhone's lost GSM signal!"

http://www.mauron.net/iphonerepair/

Was dit antwoord nuttig?

Score 0

Commentaar:

Look at page 17 in "iPhone_3G_Disassembly.pdf": http://manuals.4pda.info/Other/Apple_iPh...

door

There you'll find the Antenna Location.

door

Een opmerking toevoegen

i have same problem my iphone network works in very strong areas, n no service in another area. i have done all restore,reset etc but don't work.............. what to do

?

thanks in advance

Ramesh

Was dit antwoord nuttig?

Score 0

Commentaar:

Ramesh, the first thing that you should do is to ask your own question. Right now it appears that you are answering an old question. Nobody will see that you are needing assistance. Click on the link "Ask a question" and give as much information as possible. This way others will see you need help.Good Luck

door

Een opmerking toevoegen

Found this answer at this link. Haven't looked yet to see if this will be repairable or will fix the problem or not. Good Luck.

http://cybermog.wordpress.com/2010/04/29...

Was dit antwoord nuttig?

Score 0
Een opmerking toevoegen

Voeg je antwoord toe

Chris zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 Uren: 0

Afgelopen 7 Dagen: 0

Afgelopen 30 Dagen: 1

Altijd: 39,429