Ga door naar hoofdinhoud

4 Function Diamond Microdermabrasion Unit SLY-08XLT OR. NV-07D

9 Vragen Bekijk alle

The vacuum no longer 'sucks dry skin' it reversed to 'blow air'.

4 function Diamond Microdermabrasion Unit NV-07D or SLY-08XLT

Link below


I purchased this expensive unit for home use as a special gift for myself, in 2010, because I never buy anything for 'me' and if you have ever booked an appointment at a spa, microdermabrasion appointments can run any where from $250 to $500 per session.

The unit was used five times in 2010, then it sat until yesterday, without being used or damaged until yesterday, because I had been diagnosed with bone cancer, and went through treatments (etc...)until January 2013, and am now in remission (yay). No one used it because I had it stored perfectly safe on the floor of a cupboard that isn't frequented.

"To use the microdermabrasion area of the unit:

Diamond dermabrasion is a creative improvement of the micro-crystal dermabrasion. The diamond dermabrasion provides a non-surgical skin refinish procedure, by using sterile diamond heads to abrade or rub off the top skin layer, then vacuuming out the particles along with any dirt and dead skin backup. This procedure removes skin debris, imperfections, blemishes, wrinkles and unwanted pigmentation on the skin. Moderate usage of Diamond Dermabrasion, accompany with skin products that penetrate through top skin layer that reach the dermis level, helps to replenish natural nutrients, restore cell activity, and promote skin health. The results after Micro Dermabrasion treatment is usually a healthy, glowing, beautiful skin."

However, when I began to use the microdermabrasion section, I discovered that the suction pressure gage was not moving at all, ( this is not good for the user because, the skin can be severely damaged or scarred from too much suction, and the gage is used to keep the suction at the proper rate for different areas of the skin.).

I then disassembled the wand, hose and filter from the unit and checked for holes and kinks in the plastic hose, missing gadgets, clogged filters and found that everything was in tip-top shape (it should be after only 5 uses).

I reconnected everything to its proper place and turned the machine back on, placed the wand end to my tongue and noticed straight away that the air wasn't going in, or vacuuming, it was blowing out, like a fan.

I need to know how to repair this problem, if anyone know how. The units warranty ended last August (2012), and the company has not return my calls or emails yet. (Probably since it has only been approx. 24 hours. Neverthelessless, I would love to see some instruction on repairs to the unit, for his and all future malfunctions and their repairs.

If you have any answers or tips to repair my unit, I would be extremely thrilled and appreciative!

Thank you for listening.

Pamela Miller

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 1
6 opmerkingen

Pam, I too have requested sources for authorized service providers. I found no tear downs or repair information of any kind.


Thank you Mayer!


Pam, you could try my new guide :-) to add an image of "the guts" on here. That could come in handy to assist you in fixing it....


Wow, great new guide!


I will do that, most likely tomorrow because, as expected, 7 phone calls later, no return call. I am going to open it, and use the link and upload the 'guts' to you, maybe, if I don't figure it out, you can make heads or rails out of it. Thanks again for posting info to me! You been very gracious!


1 commentaar meer tonen

Voeg een opmerking toe

6 Antwoorden

Gekozen oplossing

Contact: Wes at <>

Or the web site here:

Was dit antwoord nuttig?

Score 1

1 Opmerking:

I purchased the diamond microdermabrasion sustem in november and it will not function since i received it, i cannot find where i can contact in regards to get a new functioning one, no paper work /receipt came with i only have the box and UPS tracking


Voeg een opmerking toe
Het nuttigste antwoord

sounds like someone inverted the fan motor leads, meaning that the fan is stuck in reverse.

I'd try through the proper channels first, but you should be able to either fix it or have someone skilled in small appliance repair fix it.

First, look through all the troubleshooting tips and instructions. Is there a setting that is supposed to blow instead of suck?

The gauge doesn't work because the air is moving the wrong direction.

Hopefully it's a fan blower, vacuum, but even if it's a pump it should work the same way. There is a AC/DC inverter and then the blower or pump is fed the proper DC voltage to run. The positive and negative wires are probably switched.

Someone else can correct me if I'm wrong, but you should look at the connections to the vacuum unit and see if you can see indications of a positive / negative wire connection.

Taking it to a TV/Radio repair service should be cost-effective as they can diagnose it quickly and resolder the motor correctly. You should be able to do it yourself too if you don't mind soldering or rewiring it.

I wish I had a photo of the guts to look at. Good luck.


Well when you take it apart you'll find out what the problem is. . . maybe. There's a good chance that the issue is actually caused by an inversion due to a malfunction in the logic or circuit board. Basically it might not be easily diagnosed when you pop the top off. Hopefully you see the problem right away.

Another thought then is that there may be an internal battery that went bad during the prolonged storage while you were kicking the $&@^ out of cancer's skanky stank (sorry we have a bit of history too).

Take a few pictures and upload them per turkey's instructions. good luck.

Was dit antwoord nuttig?

Score 1

2 opmerkingen:

Hi Daniel, first off, thank you so, so, so, much for answering!

Your reply definitely sounds plausible to me! I haven't (nor has anyone else, to my knowledge) opened this thing up yet. But, I considered the unit may have been bumped or hit as it sat in the bottom - back of a closet that is generally never accessed.... I even started to believe that there is a 'not-me' ghost, residing in my house, that breaks things like, lamps, plates, good crystal..etc! Haha.

Any way, I will look on the outside of the unit for us/overseas voltage / amp switches (right now, I don't remember seeing one, but that doesn't mean it's not there. It's possible it's inside, like you suggested. At this point, I believe that a wire may have fallen off, if it wasn't soldered properly to begin with.

I will give this company one more day to return my (now 5) phone calls and if they don't, I will open it myself, look it over and, if its simple enough to correct (like soldering), I will fix it myself. But, if it is too foreign to me to figure out, I will take a photo of the 'guts' and try to upload it to this article...the only problem about that is, that I tried to upload a photo to the original article (just the outside), and I wasn't able too, as I am only using an iPad app, (I think).

It's a shame that I have only had the opportunity to use this thing five times befor it sat for almost two years. Because after all I went through in the past couple of years, my skin really needs a refresher that only this cotton-picking thing can give! Lol... I need a spa day!

Thanks once again for your reply! I will get back to you either way and let you know the outcome!

Take care,



Hi Daniel, Turkey and Daniel, I don't know if you had the opportunity to look at the photos that I uploaded so far for the guts of the microdermabrasion unit of mine, that won't vacuum, but, blows, I will be loading up more photos of the upper portion of the unit this evening (I hope!). They are located on the disassembly guide that I started to put together for others who may have the need for it.

There are no tears, rips, holes or kinks in any of the hoses, and the filters are clean. The housing for all three filters are tightly connected and no air leaks. And as you may have deduced, none of the wires are loose, disconnected or bad.... Until I open the upper portion, I won't know anymore. It's a bit complicated to open since all of the wires and hoses are strung up through the neck and I honestly can't find an screws to remove around that area.

I will get back to you after I post the next set of images. take a look at the photos I have already uploaded, maybe you will catch something that I didn't.


Voeg een opmerking toe

Hi Daniel, Mayer and Turkey!

I can't tell you how nice you all have been in helping me with this dream machine that turned into a nightmare! Lol!! But honestly, I still haven't heard back from the supplier and I have eight calls in and 5 emails...with no call backs or emails & three strangers that I met on an app have been kinder and most likely more caring and knowledgable then they were! So hats off to you all!

Now, I got in around 10pm tonight and wasn't home all day to rip into my unit, but, if tomorrow is less chaotic, I will start with photos and try to upload each step as I go. A friend of mine, who is an aesthetician, and works all day with these machines, told me that they have fuses (sort of similar to Christmas light fuses but an inch long) behind each device connection. My machine should only have four, and I picked up a half dozen pack while I was out, hopefully I have the correct volt/watt. I am keeping my fingers crossed that its fuses out (she also mentioned her unit blows air instead of vacuuming when her fuse go out too) and not a bad circuit board - momma Mia!!! Heck I would even take a loose wire at this point! Haha!

Thank you gentlemen! Hopefully....until tomorrow.

Take care, ...Pam

Ps...Daniel.... What kind of cancer (I call it the kumsuckeruckus disease, given by a cancer succubus... Haha I had bone cancer about eight years ago. Through treatment- remission. Then six-ish years later it hit my left lung and biliary sections of my liver (lymphatic too, but everyone has lymph when it spreads). I kicked it rump and I am not letting it back in!!! Yeah! How were you affected by the monster and how long till u were in remission?

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Hello all, it is Saturday night and I spent Friday evening taking photos as I slowly took apart this unit. Upon opening, I didn't fid any fuses or batteries. The only thing that was not connected to another source inside, and may ave been left intentionally that way, was a third hose with a mini filter inside a plastic housing, one end was connected to the microdermabrasion wand interior portion and the other end, past the mini filter was a hard plastic nipple-like tip with a tiny opening at its very end. It of course was not connected to anything whatsoever. I'm inclined to think that it should be connected to 'something' as it is the portion of the vacuum system that is connected to the wand that hold the diamond tip that I place directly on my skin and is where the suction was originally felt. (And is now blowing air.

I tried for about an hour or so to upload photos, from my iPad. I am certain that I will be unable to use my iPad for this. I now will have to upload the photos I took with my iPhone on to my laptop so that I can use them in fixit. Unfortunately, it is a new laptop and I don't have it set up with iTunes yet. I will either set this up tomorrow and hopefully uplo the pictures or I can emails the pictures to one are all of you for a quick look. I would like to dd these to the device manual too for others who may have this issue but it is slow going as of now.

I'm sorry that I can't give you any better information as I am not well versed in what a vacuum setup in any device should look like. I am certain of one thing, there are no loose wires. I still have to open the topside of the unit, to see if there are any fuses or batteries on the top of the unit. But the bottom of it carries all but one hose for the vacuum portion.

I will be back soon!

Take care! Let me know if any of you would like me to email these pictures. Thank you!

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Ok guys, I have finally got it together and was able to load up the photos from the lower half of the unit. They are posted in a disassembly guide with the exact same title/name. I am on my way home and will tear apart the upper half of the unit, document it, and upload all of the photos again. Hoping someone sees something, cuz I do not. Also, I was wrong about the hose connection that I mentioned Saturday, it is actually attracted to the blower housing. If anyone has anymore tips for me at this point, I am all ears!! Thank you!

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe


Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Voeg je antwoord toe

Pam zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 4

Afgelopen 30 dagen: 26

Altijd: 8,983