Ga door naar hoofdinhoud

Released November 2018 as an edition to the iPad's Pro line. Model A1980.

62 Vragen Bekijk alle

The usb-c port doesn’t trasfer data.

I recently changed the usb-c port of my iPad because it was faulty, moving the cable would interrupt the charge and the data connection, before the replacing I tried to scratch the connection line on the original usbc port trying to fixing it but it made it worse, the iPad wouldn’t connect anymore. Then I decided to be fearless and take apart it to change the port. Now the iPad charges well but doesn’t connect to the usb, nor hub. Seems data doesn’t transfer. What could it be the problem?

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 3
Voeg een opmerking toe

3 Antwoorden

Gekozen oplossing

I'd suggest double-checking the FPC plug going from the USB port to the motherboard. If it's not fully seated you could conceivably be getting power connections but not all of the pins making contact meaning the data connection's not working. Unplug it and check both sides for bent or broken pins; use a magnifying glass and a bright light. Bent pins can sometimes be straightened with some fine tip tweezers, but of course broken ones are more problematic.

Clean both sides with 90% or higher concentration of isopropyl alcohol and reconnect then see if it's working before you button everything back up. If it's still not working and you still have the original port, try plugging that one back in and see if the problem persists. If that fixes it, you'll need to get in touch with the iFixit Store people for a replacement part. I know they try to do their best to provide the highest quality parts possible, but it's just a fact of life that sometimes they get shipped a bad apple.

Was dit antwoord nuttig?

Score 2

4 opmerkingen:

Ok, soon I’ll try. Thank you for your time

door

i tried and i got the same resoult with the original port. im starting to think i fried something when i attempted to fix the original port by scraping the contacts. could be the usb contrller chip?

door

@niccolo96 Yeah, that's a possibility; the 5V that is present on the power pin can easily be shorted over to one of the other data pins if you use a metal/conductive tool on the pins without disconnecting the battery.

I'm afraid I've reached about the limit of my expertise on your iPad, so unless someone else pops up with more suggestions, you may be at the point where you'll have to get a professional technician to take a look at it.

door

Thank you for the time you spent helping me.

I’ve reach the end with this iPad. For what I remember it stopped working when I connected it to a pc, the USB-c port connector was destroyed, I think somehow when I connected it some traces got connected together and fried the usb-c chip.

door

Voeg een opmerking toe

Some USB-C cables are not fully wired intended for power not data.

Was dit antwoord nuttig?

Score 1

5 opmerkingen:

I bought the spare part from ifixit, i don’t think is a limited usb-c, nor there was written anywhere.

What could it be?

door

@niccolo96 - There are different aspects here to consider. The physical connector on the device (USB-C) and what the communication protocols it supports. The USB consortium also fumbled! Adding a bit of confusion into the mix as well. To simplify things here the protocol is strictly USB 3.0 support, the connector use creates the confusion of offering USB-C performance as well as many people assume it’s Thunderbolt-3 which it isn’t! The newer generations offered better protocol and performance support.


The issue here is not all of the pins are wired for data so you do need to be mindful of the cables abilities and what it are trying to connect to.


So maybe we need to get a better idea what you are attempting to do.

door

Mmm, I bought the part number EU323045-2 , the description says that’s compatible with my iPad, the name says third generation which the iPad isn’t.

Regarding of cable I’m using, I’m using a usb 3.0, but anything related to data transfer does work. USB hub doesnt get recognised. USB-c DAC are not recognised. Connecting an iPhone with usbc to lightning doesn’t make the iPad recognise it. I can only use chargers, fast charging does work

door

@niccolo96 - So the issue then is within the replacement part. This was a working setup before you swapped out the connector correct? If the connector is not the issue then it could be when you tried cleaning things did you power down the device before you scraped the contacts?

door

i couldnt really shut it down, the ipad got some software issue and when shoutting down it would start itself up again, that's why i wanted to change the port. i solved the software problem by upgrading the OS, but this was after the replacement part, I’m starting to think that something could have been fried between the scratching part, and it's behaviour. i tried taking apart the ipad onther time and connecting it it's original port and i get the same behaviours. could be the usb contreller chip to be fried?

door

Voeg een opmerking toe

It could be the replacement usb port being incapable to transfer data or a fealty installation of a fealty usb wire

I hope this is helpful

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Voeg je antwoord toe

NiccoloMartini zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 2

Afgelopen 7 dagen: 11

Afgelopen 30 dagen: 53

Altijd: 138