Ga door naar hoofdinhoud

Released June 2012 / Core i7 processor with Turbo Boost / Up to 1 GB GDDR5 Video RAM

597 Vragen Bekijk alle

No power on, no boot

Hello! I have a 2012 15” Unibody MacBook Pro that I have had since new named Grandpa. So yesterday I was trying a seam game (Timberborn), and he got really hot and shutdown unexpectedly. I thought Grandpa just needed a nap. Now about a week later I get no boot. No power on. Nothing. The MagSafe light shows green but the battery doesn’t charge (it’s a replacement from about 4 years ago). Things I’ve tried:

  1. SMC reset doesn’t help.
  2. Disconnecting the battery internally and trying to boot.
  3. Disconnecting the keyboard and bridging the pads above the keyboard connector.
  4. Checking all internal cables.
  5. Playing with installed RAM (switching slots, removing sticks)

Anything else to try?

Thank you!

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe

1 Antwoord

Gekozen oplossing

Disconnect the battery again, now with nothing else connected, press an hold the power button for a good 15secs to fully discharge the logic board. Now only reconnect the MagSafe the system should spontaneously start. Let it finish the bootup and do a proper shutdown reconnect things that should get you going but there is still the need for a new battery.

Was dit antwoord nuttig?

Score 1

3 opmerkingen:

Just to confirm… “nothing esp connected” means no external devices? Sorry the ignorance.

door

Hello Dan. So I tried that. Disconnected the battery and MagSafe. Held the power button for a good long time (about 30 seconds) and reconnected MagSafe. Then I pressed the power button as normal and still nothing. I even held the power button for 10 seconds and nothing.

I tried once more to discharge the logic board but waited a minute before connecting MagSafe again. Still nothing.

Thank you so so so much for your help!!!

door

@thebuccane23216 - Yes sorry typo still sucking down my first cup of morning Joe.

Not good! This looks like a logic board failure which will need someone with deeper skills to diagnose. If you take the logic board fully out and inspect it I think you'll find a either corrosion or capacitor damage.

door

Voeg een opmerking toe

Voeg je antwoord toe

TheBuccaneerGentleman zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 3

Afgelopen 7 dagen: 5

Afgelopen 30 dagen: 7

Altijd: 40