Ga door naar hoofdinhoud

Released September 21, 2018. Models: A1921, A2101, A2102, and A2104 / Available as GSM or CDMA / eSIM or nano-SIM / 64, 256, or 512 GB / Silver, Gold, or Space Gray (Pronounced "iPhone 10 S Max.")

381 Vragen Bekijk alle

[ Solved] Panic Full i2c0 CheckBusStatus SCL is stuck low issue

So with my iPhone when plugged in to charge and turn off the screen, about 20-30 seconds later it won't be able to turn on anymore, force me to unplug the charger to make it power on and show apple logo, even plugging in lightning to 3.5mm adapter will make it suddenly shutdown. Does anyone here know if this panic full is related to hardware or software failure?

Block Image

Solved: I replaced the charging port and it actually fixed that problem

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe

1 Antwoord

Gekozen oplossing

Hi Kiyoshi,

The panic log you've posted is showing that an I2C bus clock line is stuck low somewhere. I2C0 goes to the wide angle camera, the battery connector and the charge port assembly, and a couple other places. So yes, this is a hardware failure.

We saw the same error on an iPhone XR a year or so ago, and in that case it turned out to be the charging port flex assembly. That's where I'd start, with replacing that.

SOLVED: iPhone Xr randomly bootloop at random moment - iPhone XR - iFixit

Was dit antwoord nuttig?

Score 3

5 opmerkingen:

@flannelist, you helped out on that previous issue; does it look likely this is the same problem?


@dadibrokeit I could swear I posted a response to this, but I guess not.

I would also add the "sensor flex" at the top of the display to your list of i2c0 components.

It's definitely in the same family of problems. "Stuck low" could mean there's a short on that line. And unfortunately, a short in one place means a short on the whole line. So any of the included parts, or the board itself could be at fault.

I was hoping the panic might specify a specific problem part, but it does not. Either way, I think charge port is a reasonable start. Even opening the device, disconnecting the charge port flex cable from the logic board (after disconnecting the battery of course) and then trying to power on (after reconnecting the battery) could help to confirm. Although that may not help, if the battery is not charging properly either. You can rinse and repeat with the other items on the list as well if the charge port isn't the issue.


@flannelist Good point, rather than starting with randomly replacing parts, definitely a better idea to try and isolate the fault first. Another set of eyes always helps, so thanks!


It's strange that when I disconnect the flex sensor, even though it loses face id, true tone and auto brightness, suddenly it no longer shuts down when charging. Maybe I found a solution by replacing the flex sensor assembly


@kiyoshi1407 There's a thread on Reddit about a XS (not Max) where they're saying there are a couple of different ways to get Face ID back; apparently if you jailbreak your phone you can read out the Face ID information and reprogram it into a new flex cable, or you can desolder the dot illuminator and move it to a new cable. Depends on what's wrong with your existing one; if it's the flex cable then the second option would be feasible, but if your dot projector has crapped out then you'd need to go with the first one.


Voeg een opmerking toe

Voeg je antwoord toe

Kiyoshi zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 35

Afgelopen 7 dagen: 177

Afgelopen 30 dagen: 734

Altijd: 11,110