My iMac G3 DV SE is not powering on after trying to force CD eject

A friend gifted me this iMac a couple of days. It had MacOS 9 and I wanted to update to 10 and also erase the data, but when I tried to boot from a USB the Mac didn’t recognise it, so I got a DVD to burn and put it in the Mac but it wasn’t appearing, so I tried to eject it but it said it couldn’t eject the drive. I search and I saw in an Apple forum that you could shutdown the computer while pressing left button of the mouse and turn it on while holding but it didn’t work, so I continued searching and I found that the hole next to the CD reader you could put the tool you use to eject the SIM at the iPhone, so I tried but it didn’t work. I wanted to try out another time to force eject from the OS but when I turned on the button turned on orange, in an Apple forum said that I should reset the PMU by pressing a button on the motherboard I did and now it powers on and shutdown immediately.

Also I read that it could be the battery but I don’t think this could be it has to be related with the disc.

Is there a solution without doing a hardware repair?

Do you think it could be the battery?

How could the iMac not turn on trying to eject the drive ?

Does that hole used for other things than ejecting the drive?

Thanks for your time and your answers!

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe