Ga door naar hoofdinhoud

Repair manuals and information for the Microsoft Surface book line of laptops.

202 Vragen Bekijk alle

Tablet Battery Not Charging

My tablet battery was bloated but working. I have replaced the battery twice and it will not charge now.

The status in the lower right shows Battery 1: 0% and Battery 2: 100%.

If I go into the Microsoft Surface Diagnostic Toolkit and click on the battery section on the left side, it shows Battery 1 Discharging and 34% current charge. It shows Battery 2 Charged and 0% current charge. I think maybe the diagnostic has the batteries switched around. The fact that it thinks the battery is charged and yet it is at 0% makes me think maybe there is a software problem and the computer thinks the battery is charged when it isn’t.

The MS Battery Report does not show a manufacturer or serial number for Battery 1. It does show capacities in mWh. Battery 2 shows all information.

Any ideas would be greatly appreciated.

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 5

4 opmerkingen:

Hello, John, I am having the same exact problem. I am in the process of changing the screen battery to see if that solves the problem. I just recently changed the battery in the keyboard Bass and that part is now charging well after a swollen battery replacement. Have you had any success at all?

door

Reginald - unfortunately, after replacing the screen battery twice and breaking the screen in the process ; ) I never got it to charge. I returned both replacement batteries. I'm running without a battery in the screen now. No bulge, no screen battery, no worries about a fire. I hope you have better luck. It may be helpful for you to know that the computer runs fine without the screen battery, just less battery time available.

door

Hi John, Thanks for your fast response. I tried to heat up the screen but after removing the screen was damaged. I'm ordering a new screen digitizer from eBay for $117 to$149. About 85% of battery replacements cause a broken screen. My screen was not swollen it just stopped charging after the swollen base battery. Everything worked but the tablet battery stayed at 0%. I'm, looking at an SB i7 screen with 16GB ram. Not sure if an interchange screen would work. I did learn to never again be a Microsoft fanboy :) Got stiffed with the Microsoft Phone also suffered from a swollen battery then Microsoft abandoned the phone. Microsoft or Adobe never fixed the size problem in PS and PR without a hack. I never buy proprietary Apple products. My lesson, wait before taking the plunge. The battery problem probably won't change after screen, digitizer, and new battery replacements. I totally lost faith in Microsoft products.

door

My battery one shows charging properly on the report pulled up on the command prompt; but when I hover over the battery icon in the taskbar, it shows ZERO % - is that just because I'm not using it at the moment, I'm using the battery within the keyboard? I just bought this.

door

Voeg een opmerking toe

2 Antwoorden

Their is the possibility that the ribbon cable that connects the battery to the charging ports might not have been connected, or might be unseated slightly. Definitely go back through and make sure that the charging ports are connected to the battery.

Was dit antwoord nuttig?

Score 0

5 opmerkingen:

I don't see how this could be the problem in this case. The charging cable plugs into the base of the Surface Book where the keyboard is. The base/keyboard connects to the tablet and has a data and power connection there. The data is working as the screen is working. The battery itself connects to the circuit board via connections that screw down tightly against the battery contacts.

door

Ah, I see now. Which model of Surface Book are you using? I know that their are some that have several different ways of charging rather than charging through the base.

door

It is the original Surface Book. It can be charged with the power cable connected directly to the detached tablet but the battery does not charge this way either. The tablet will power up when connected to the power cable, but will not run off the battery obviously.

door

@joncalkins So then I wonder if the point where the logic board where the battery makes contact is making good contact with the board. Their is a point where the board has a hole for a screw where it locks in the battery and the board.

door

That is logical but I don't know how the connection would not be good. I have also read that the battery can report as not present and that is not the case for my situation.

door

Voeg een opmerking toe

Having same issue after replacing the screen battery. It shows in device manager, but does not charge. Anyone able to figure it out?

Was dit antwoord nuttig?

Score 0

4 opmerkingen:

same here, i already tried with 2 different batteries (different brands) for the screen and none of the works, battery report shows as no batt installed, one of them shows the charge but it doesn't work when I unplugged the external power nither charge, the otherone shows as -1 (or 255% charge in the systray)

i've been working on this for 4 days now, one thing i found is that the board of the batteries are different and that seems to be the issue, the surface does not communicate well with the electronics

i've tried many different drivers but none of them works 100% well

try one of the new-ones from here and let me know

https://www.catalog.update.microsoft.com...

next step for me will be trying to fresh install windows, but it has to be a driver issue

door

I just found out that it seems that

G3HTA020H is for Surface Book 1 (1703/1705)

G3HTA044H is for Surface Book 2 (1832/1834)

batteries look the same, but the electronic board is different, Surface Book 1 will not recognize G3HTA044H giving the odd status of 255%, and will not charge

door

@Leandro is it possible to transfer the electronic boards or is it too embedded into the battery. If it is too embedded in then maybe try buying a dead surface book and taking it apart considering it would appear you were able to do so for you current one.

door

still trying to make this to work, I've been using the surface as a desktop connected to an external monitor.

I did try to transfer the electronic board from the old swollen batt to the new uncompatible one but it seems that the electronics burnt out in the process of soldering the board to the batts

After some time i dive again in ebay and found an original G3HTA020H in france, bought it and now the batt shows up ok in the battery report, serial number and stuff but still not charging, battery is close to flat at 2%

in the envet log i found kernel errors saying that cbatt.inf failed to start

I've tried all the drivers versions i have, none of the works.

I'm so frustrated, this is the 5th batt and i bet that this should work as it is the first one i try with the original part num, batt looks exactly the same as the original ...... i'm suspecting that after so many attempts i might broke somthing in the board? hope not.

next move will be remove the batt again, charge it outside to full and try again

door

Voeg een opmerking toe

Voeg je antwoord toe

Jon Calkins zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 5

Afgelopen 7 dagen: 27

Afgelopen 30 dagen: 145

Altijd: 5,416