Ga door naar hoofdinhoud

The 2014 edition of the Kindle, part of the 7th generation, includes a touchscreen and same form-factor as the Kindle Paperwhite, but lacks the backlight.

29 Vragen Bekijk alle

Trying to track "power on" track for Kindle 7

Hi everyone,

I have an Amazon Kindle Fire 7 Kids sr043kl that I’m trying to fix. The power on button does not appear to be working but the power can be turned on by plugging the device into a USB charger. Once on the device is fine but again the power button will not turn it off.

I’ve opened up the device and removed the motherboard. I can see the power button contacts and I can confirm that there is momentary continuity when the button is pressed (BLUE bit on pic). I have tried jumpering the power contact to a ground to try to emulate the action of the power button but it’s still not coming on, so my next plan is to try jumpering further up the track. Trouble is I can’t see where the track goes.

Does anyone know where the track ends up (I’ve pointed it out in RED below)?

Block Image

Many thanks,


Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe

1 Antwoord

Het nuttigste antwoord

From what I can see, it looks like you've got a lifted pad there where it says pwr. I'd suggest taking an exacto knife and carefully scraping the coating off the traces on each side then apply a tiny bit of fluid and wider your jumper wire right over the pad from one trace to the other. Hopefully that's making sense. Following your red arrow you'll see the missing gold pad. I'd recommend cleaning that area with some 91% iso alcohol as well. It almost looks like water or moisture got in there. Hope this helps.

Was dit antwoord nuttig?

Score 1

2 opmerkingen:

Thanks for taking a look. I hadn't noticed the discolouration of the copper on PWR, I guess that was the original problem. I'll give the board a bit of a clean as well.

The bit that I've arrowed in red (and the one above it) are metal springs that press against the copper contacts that I've shown in blue. I think that's what gives them the appearance of a lifted pad but they look ok when looking at them live. Now that you've pointed me at that though I can see a track that looks like it goes from that spring to the discoloured PWR copper point (and no continuity). Testing it with power it appears that there is no power to the spring.

I think you've put me on to the right tack. I'll try that and let you know.


The discolored copper was the pad I was referring to. That trace was the one I was talking about when I said to scratch both sides lightly and solder a small jumper across the pad "discolored copper". You should have no trouble scratching through the green coated to fresh copper on both sides. That discolored area or pad (just so we're clear we are talking about the same thing) has to be repaired for your switch to work. No continuity means you've found your problem. At least the start of it anyway.

Let me know what happens good luck


Voeg een opmerking toe

Voeg je antwoord toe

David F zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 0

Afgelopen 30 dagen: 2

Altijd: 59