S7 not working without charger and stuck in a boot logo loop.

Hi, some months ago I broke the glass in the back of my phone when skateboarding. After that, the phone turned off as if it didn’t have any battery left. It wouldn’t turn on again. Then when I plugged it in the charged it was shining the red light as if charging, and the charging symbol popped up on the screen, but it only goes up to 4%. The phone boots back normally and displays the lock screen, but it immediately turns back off. I don’t even have time to unlock it before it’s gone again. I wonder if after the backscreen broke my brother used it to listen to music in the shower and vapor got inside of it.

  • Only charges to 4% (If I’m not mistaken it doesn’t even charge 1-2-3-4%, it just shows 4% all the time)
  • Is able to boot, but immediately shuts off again.
  • The light in the top, the lights from the buttons next to the home button, and the vibration are all working properly.
  • Only turns on when connected to power.

UPDATE: While writing this, I managed to put the phone in the Maximum power saving mode, and then the phone shut down. Now the phone is displaying “Samsung Galaxy S7” in a loop. Pressing off + home + Volume up doesn’t work, neither does every combination I’ve tried. The only one that works, though, is Home + off + Volume down, which enters the Odin download screen. Weirdly enough the phone is not shutting down on the warning screen. Rebooting after this still doesn’t help

Does anybody know how to fix this?

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe