Ga door naar hoofdinhoud

Repair information for the SteelSeries Arctis Pro wireless headphones. Released in March of 2018. Model number: 61743.

48 Vragen Bekijk alle

Battery station not charging the battery

Whenever the battery is in the battery station it shows that it is fully charged but when I put the battery in the headset it doesn’t turn on as if the battery is empty.

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 3
1 Opmerking

im having the same problem. looking for a solution

door

Voeg een opmerking toe

5 Antwoorden

Het nuttigste antwoord

I had the same problem as i just swapped my batteries out and it’s just died on me. Now the base station says ‘‘charged’’ for some reason. So, i quickly googled and someone said to try taking out all power to the base station for a moment, so i did for 30-60 seconds. Plugged it back in. Battery is now charging. It seems because of how long it remains on, the firmware glitches and fails to tell the base station to charge the batteries. Definitely doesn’t seem to be hardware related that’s causing it. Try turning off the power completely for 60 seconds and reconnecting it.

Was dit antwoord nuttig?

Score 6

1 Opmerking:

This is what solved it for me. However! The battery only started charging again when it was inserted and I unplugged/replugged the base. When I took the battery out first, then unplugged, then replaced it the issue did not go away.

door

Voeg een opmerking toe

There might be many possibilities that your steel series Arctis Pro Wireless headphone won’t turn on.

  • Your headphone has some internal issue if there is no light on the headphone.
  • You're charging station has some fault, and it won’t charge the battery.
  • Last option battery is no more in working condition. Every battery has a life span. Maybe your battery is old.

To verify all the possibilities, buy a new battery and check with that.

Was dit antwoord nuttig?

Score 1

1 Opmerking:

This is terrible advice. The person didn't state how long they'd had the device for you to conclude it's the batteries.

door

Voeg een opmerking toe

Hi Micah,

I got the same problem.

When I put the battery in the charger I have to tweak it a little until the display show that its charging.

I guess its the contact inside the battery station that is the problem. Its really annoying that its not working properly.

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

I had the same problem. I even disassembled the charger but i could not find the problem other than i thought it must be corrosion. I bought a fiberglass brush and cleaned the pogo pins on the charger and on the headset. Then I cleaned the contacts on the batteries.

That’s it. Now it’s working :D

Edit: You should be able to clean the pogo pins of the charger without disassembling it, through the battery slot.

Was dit antwoord nuttig?

Score 0

3 opmerkingen:

I highly recommend NOT doing what this person said to do, you could risk damaging it more. What i find worked for me just now is unplugging the device for 60 seconds and re-connecting it. The software on it seems dated so probably bugged/malfunctioned. Just needs a hard reset.

door

For me this does not work, as i turn off the power to the charger every night.

For me, it really was a corrosion problem. But if turning it off and on again works for you, great.

door

Hey Marcel, can I know how you opened it?

door

Voeg een opmerking toe

Yep I have the same problem I took a flashlight to look in the box and I saw that the three charging prongs inside were a bit bent to the right if you have this same problem wiggle it around to the opposite direction it won't fix it but it will charge :)

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Voeg je antwoord toe

Micah Lee zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 32

Afgelopen 7 dagen: 209

Afgelopen 30 dagen: 903

Altijd: 10,148