3DS XL wont charge (Nor does the charge LED light up)

I'll try to keep this simple and sweet. I have a 3DS XL that won't charge (the charge LED doesn't light up either). The 3DS XL works fine with a charged battery but it's impossible to charge the battery.

I noticed that whoever attempted to repair it put the incorrect charge port in it (they put a New 3DS XL charge port which doesn't fit) I change the charge port to the correct one but it still doesn't charge. I tested a few components around the charge port for shorts and there were a few anomalies. 

The far-right pin on the charge port shorts, there was no continuity with the F1 fuse, the component EM1 is shorted on all sides, the component next to EM1 (left side) shorts on both sides, the bottom right pin of the charge chip (the chip nearest the charge port) is shorted and on the backside of the board, TP7 is shorted. All of these compared to a working board are issues. But I cannot find a common cause/what the issue is that is causing all of this.

Note: F2 fuse tested to be fine

I have already replaced the fuse with a known good fuse (fuse works well now), I replaced the EM1 component and replaced the charge chip with a known good. None of them fixed the issue and now I am confused about what it might be.

Note: I tried to do just a simple reflow for the MCU as well

The only thing I haven't replaced is the MCU under the metal shield, and that would be my next logical step.

But before that, I wanted to see if anyone knew anything I should check to figure out what is causing it not to charge and why many things are shorted. Or if anyone knows exactly what is causing this.

Thanks in advance.

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe