Ga door naar hoofdinhoud

Apple's third-generation smartwatch, with optional cellular connectivity, released September 22, 2017.

197 Vragen Bekijk alle

Apple Watch 3 won't start up past Apple logo after battery replacement

Hi Team,

I just replaced the battery of my Apple Watch folloing this iFixit guide with the iFixit battery replacement kit.

Before sealing the watch, I tried to restart it to no avail. I placed it on the charging pod and it displayed the “snake screen”, meaning I guess the battery was completely empty. I let it charge for a couple of hours, but I can’t get it starting again.

Just pressing the side button doesn’t do anything.

Doing a force restart pushing both the side button and the digital crown for 10 seconds does indeed bring up the apple logo , but after that nothing happens. The logo stays on for some time (varying between on minute to more than 10 minutes) than it disappears….

I tried to disconnect and reconnect the battery, to no avail.

Is there anything I can do to bring this watch bach to life ?

Thnx a lot fort your help !

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 2
Voeg een opmerking toe

1 Antwoord

Het nuttigste antwoord

I have exactly the same issue. In fact, I have also changed the Force Touch just to rule out that in the process of changing the battery it would have been damaged for some reason.

It seems it keeps on a continous boot loop, only showing the logo, even though I tried a hard reset with it (with and without the charging stand).

It’s also partially connected to the iphone, as I can modify certain parameters as volume o the speed of the speech from there, but not the “find my apple watch” button.

Any idea?

Was dit antwoord nuttig?

Score 1
Voeg een opmerking toe

Voeg je antwoord toe

Jean-François Schmitz zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 3

Afgelopen 30 dagen: 6

Altijd: 701