Upgraded RAM. Mac mini won’t boot even w/ original RAM

Upgraded the RAM on my Mac Mini (Late 2018) using OWC modules following the OWC video and iFixit guide. Mac mini did not boot up: “on” indicator did not light up, no display signal, but a USB dongle (an iLok) lit up, so there seems to be power. I also tried turning on the Mac mini without the USB dongle, but there was still no display signal nor did the on indicator light up.

I reinstalled the OWC RAM modules a few more times checking every connection, checking for secure seating of the modules, checking every screw, looking for damage to any component. Still no boot.

So I reinstalled the original RAM modules, again checking for every detail including correct seating. No boot even with original RAM modules.

Called OWC technical support. We checked for correct seating of original RAM modules and logic board. Still no boot. Suggested I have Mac mini checked.

I have resigned to take my Mac mini to an Apple authorized repair place this weekend. But I am just wondering: What could have technically happened in this case? Electrostatic discharge? Manufacturing plant resin from the OWC modules got into the sockets? Just what could cause my Mac mini not to boot up even with original RAM.

Hope someone here could identify a mistake on my part, so I could fix it. These photos are of my last attempt to install the original RAM modules and check all components:

Block Image

Block Image

Block Image

Block Image

Block Image

Thank you in advance !

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0

1 Opmerking:

Hard to say, sorry ;-{


Voeg een opmerking toe