Trying to Reuse Internal Fusion 3TB HDD After Upgrading iMac to SSD

I’ve just successfully swapped out my 3TB fusion drive with an SSD. (The internal blade 128GB fusion SDD was failing but the HDD was good. This is now the second 128GB fusion SDD to fail so I’m done with fusion forever!)

After completing this, I decided to use the former hard drive in an enclosure. Sounds too easy! And of course, it isn’t.

The OS sees the drive upon bootup but says “The disk you inserted was not readable by this computer.” It offers to select “Initialize” which takes you to Disk Utility where you can run First Aid. This runs successfully but the drive is still not useable. Disk Utility shows SABRENT Media 3 TB external Physical Disk but Finder still doesn’t show it exists. I’m thinking I should have done something to break the fusion before I removed it but I didn’t anticipate this issue. Now the iMac is all sealed up and I’m not going back in!

Can I do anything to gain access to this disk for reuse? I would like to keep the contents as-is for a sort of extra backup, but if all else fails, I could resort to reformatting it so I don’t let 3TB go to waste.

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0

4 opmerkingen:

What is the macOS release your system is using?



I'm running Mojave


What was the system you were using when you had the Fusion drive set up?


@mayer Just the standard iMac with fusion drive, running Mojave.


Voeg een opmerking toe