Ga door naar hoofdinhoud

Model A1419 / EMC 2806 / Late 2014 or Mid 2015. 3.3 or 3.5 GHz Core i5 or 4.0 GHz Core i7 (ID iMac15,1); EMC 2834 late 2015 / 3.3 or 3.5 GHz Core i5 or 4.0 GHz Core i7 (iMac17,1) All with Retina 5K displays

268 Vragen Bekijk alle

Performed PSU Swap - Worked for a while, then POP! Dead iMac?

Hey all,

I performed the PSU replacement tutorial as listed here. I purchased parts from here, followed the tutorial to a tee, everything went perfectly, no probs!

iMac performed as usual for one evening (just browsing and iTunes) then today I was editing a video in Final Cut Pro when about 2 hours into it I hear a very audible “POP” noise, a fuse tripped in my house power box and there was a sketchy electrical smell from the top of the iMac.

Any ideas what to do next?

I’m half thinking to bite the bullet and contact Apple, however I’m reluctant as my initial post when this started happening over on the Apple Discussions Forum has gone unnoticed: https://discussions.apple.com/thread/250...

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 1

Commentaar:

First Apple doesn't answer most of the posts in the discussions.

door

Yeah, that's been my experience over the years too...

door

Een opmerking toevoegen

PC Laptop batterijen

An easy fix for a big power boost.

Nu winkelen

PC Laptop batterijen

An easy fix for a big power boost.

Nu winkelen

2 Antwoorden

Het nuttigste antwoord

First its sounds like you have a power issue within your house power wiring.

First you should go to your local hardware store and get a simple plugin power tester something similar to 3-Wire Receptacle Tester There cheap and give you a simple Go-No Go test. Make sure your outlet is properly wired.

You should also check your breaker panel to make sure its properly grounded. Your ground line should be attached to a metal water line exiting the building or tied to one or more grounding rods buried into the ground.

Even still you should have a good surge suppressor or better yet a good UPS. Do make sure all of your peripheral devices are likewise plugged into the same surge suppressor or UPS. If your system is wired to a network make sure you have the other devices are likewise in their own surge suppressors and you’ve checked their outlets as well.

The next thing you’ll want to do is contact your power provider asking them to lend you a power meter for a couple of weeks as I suspect you are encountering power issues. These just plug into a spare outlet and monitor the fluctuations of your power and can be printed out to review. That should give you guidance on whats happening. Some of the better UPS’s offer this function as well.

As far as your system, contact iFixit to get a replacement. Hold off putting it in until you’er sure the power issues have been fully checked out.

Was dit antwoord nuttig?

Score 4

Commentaar:

Hmmmm, powers urges to the house have never been a problem in the past Dan, but I will look into it.

Is it possible I have used the incorrect PSU? The part number I ordered was:

IF174-014-1

door

IF174-014-1 is the iFixit inventory number its not the Apple spares part number which is P/N 661-03524.

In any case you ordered the correct part.

door

Yeah, after checking it out further I definitely ordered the correct part. Very confusing that this should happen.

door

I'm suspecting you have a hot ground. This could be a badly wired device, more often its the outlet is miswired.

door

Hmmm, the more I look into it the more I am leaning away from the power being the issue. I mean, if it were everything else on that board would have blown too right? On that board I had a GoPro charging, a LED light rack and a Mobile Broadband modem and all of those appliances were not effected by the "POP!!".

door

6 commentaren meer tonen

Een opmerking toevoegen

After emailing with iFixit, their excellent customer service advised they would send out a replacement PSU (and adhesive strips). Awesome!! I was so impressed with iFixit shipping times from USA to Australia on my initial order the other week I made a video about it: https://youtu.be/9n5KIHD1f8M

Anyway, the FedEx guy arrived today and oddly the replacement only included the adhesive strips, no PSU. This was obviously a mistake so I’ve sent off an email to work out what happened. I included images of the package and how it arrived here (1 bubblewrap “envelope” with just the adhesives/pizza cutter - labelled as “1 of 1”).

In the meantime, I set about opening my iMac again as I’ve heard it’s extremely difficult to remove newly added adhesives. That was indeed correct and I created a decent crack on the left side of the screen doing so. Totally my mistake. I was kinda !#^&@@ off that the PSU didn’t arrive as it means missing another weekend of live streaming on my YT channel while my iMac is out of commission. I accept I used too much force with the pizza cutter. Lesson learnt.

Block Image

After taking the faulty PSU out (I made another video: https://youtu.be/c4StaBnYu0E) I noted the blown part was (so I’ve been told) a Thermal Switch?

And so that’s where we are right now. I’m awaiting reply from iFixit to see where the actual replacement PSU wound up and we can go from there.

At least having this image of the blown out part will possibly help someone else?

The initial replacement PSU:

Block Image

Enlarged to show blow out:

Block Image

Was dit antwoord nuttig?

Score 0

Commentaar:

Received the second replacement PSU today, it's all in now and been running for the afternoon with no issues.

I actually have not sealed up the screen yet but the adhesives are in place. I think I want to see at least a weeks worth of use before I am confident to use the adhesives - last time those fresh adhesives were almost impossible to get off!!

door

Happy to here you got your system up and running!

Don't forget to score and accept the answer.

door

Well, it's been running for 4 days right now, but I still have yet to close the screen. I guess I don't really fully trust that it's gonna last lol!

door

ARGHHHHHH!!!! For real!! It just "popped" again after almost a week of steady usage!!! I'm GUTTED!!! WTF????

door

Get the line meter from your local power supplier keep it for a good month. You could also just jump to a good UPS which offers line monitoring.

door

3 commentaren meer tonen

Een opmerking toevoegen

Voeg je antwoord toe

Benon Koebsch zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 Uren: 0

Afgelopen 7 Dagen: 1

Afgelopen 30 Dagen: 1

Altijd: 134