Ga door naar hoofdinhoud

The TI-Nspire CX handheld features a full-color, backlit screen, thin sleek design and includes TI-Nspire rechargeable battery.

35 Vragen Bekijk alle

disassembly guide for nspire cx yellow edition

this nspire model differs from both the standard CX and the grey school edition with yellow highlights.

I see 4 screws to remove, but am still unable to disassemble.

Screen flashes white briefly when USB cable is plugged into power source, but does not boot or power on beyond the flash.

Block Image

Block Image

Update (04/16/2019)

All visible screws have been removed.

Block Image

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 1
Voeg een opmerking toe

3 Antwoorden

Are you sure you should be taking apart school property? ;)

Anyways, you need to remove all the rubber feet on the calculator since there are screws under each of them. Also, I believe there are more screws located underneath the battery. You will need to remove the battery cover, then remove the battery itself, then you should be able to see the screws. Remove those and you should now be able to pry apart the calculator.

Could you please tell us exactly what’s wrong with your calculator? It may not require you to disassemble it.


If your calculator is acting like that then there’s most likely a software issue and (hopefully) not something with the hardware. There are a few things you can try to get the calculator working. (I got this info from TI Planet )

Press the reset button, then hold down the keys:

(Some combinations are handled by the boot1 (earliest stage) and cause their effect as soon as the device is (re)starting.

Others are handled by the Boot2 and cause their effect when the loading bar is over 50%.)

This launches the diagnostic software, if present (non-dangerous choice, AFAIK)

* [esc]+[menu]+[-] (Boot1)

This goes to the Maintenance Menu (allowing you to delete the OS, etc.) (no effect if nothing if cancelled - not dangerous)

* [doc]+[enter]+[EE] (Boot2)

Try getting to the diagnostic software, if you can, see if you can find what's wrong. If you don't have diagnostics software proceed to the next part

Try using the Maintenance menu to delete the OS then get the latest OS from TI's website and install TI-Nspire Computer Link (for windows and I think also mac) then send the newest OS to your calculator. Hopefully your calculator should start working again, if it doesn't, try launching the diagnostics again. If diagnostics still doesn't work please reply and I'll try to get some more help.

Was dit antwoord nuttig?

Score 0

6 opmerkingen:

The screen flashes white for an instant before going black. This is both with and without the battery in it. The charging light does the same simultaneously when the battery is in place.


I tried to comment a reply but it was too long so I've edited my answer instead. Look at whatever is below the bolded "EDIT:"


Hi @thelastmill ,

FYI if you wish to post a long comment, write down the entire comment and then highlight and "cut" (right click mouse) anything over 1024 characters (or guess the amount), post the comment and then go back to "edit" the comment, "paste" (right click mouse) the rest of the comment below the existing comment in the edit box and then post the comment again.

Result, comment longer than 1024 characters.



Thanks for the advice. Unfortunately, the button combinations did not make a difference. I tried both the negative and minus keys for good measure, but none of the three made a difference.


Thanks for the tip jayeff, I'll keep that in mind!

Athan quick question, did you try used a new battery? I know you tried taking the battery out and putting it back in, but the battery health could be completely dead. When you get your new battery (you can try this with your old one but it may not work) make sure to use a 2 amp charger and leave the Nspire charging overnight.


1 commentaar meer tonen

Voeg een opmerking toe

OK, so I have officially destroyed a calculator attempting to take it apart but all is not lost. I have found out how to actually do this now. There are 4 screws (two under the rubber foot pads at the top) on the back of the calculator. This is not the end of the screws though. There are two screws under the screen cover that is glued/taped into place. You will need to remove this clear plastic screen cover first in order to access them. Making things further difficult these are a security screw I have never encountered before. It is almost hourglass shaped. They are located in the spots shown in the attached image. It is likely easier to remove this if heated. I cracked it by prying to hard and quickly.

Block Image

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Since the screws are under the display cover, it is no longer possible to open the housing without damage in order to clean or repair the device. A step back from Texas Instruments!

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Voeg je antwoord toe

Athan Alexander zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 2

Afgelopen 7 dagen: 12

Afgelopen 30 dagen: 33

Altijd: 1,243