Ga door naar hoofdinhoud

Model A1312 / Mid 2010 / 3.2 GHz Core i3 or 2.8 & 3.6 GHz Core i5 or 2.93 GHz Core i7, ID iMac11,3

361 Vragen Bekijk alle

No video signal to display socket. No problem with external display.

Dear Ifixit team,

My 2010 iMac does not power up the display. I’ve checked the ribbon cable and connectors. Everything is fine. I’ve measured the signals to the display. It seems that there is no video signal. There is no boot fault sound. The iMac is working except the display, it’s working on the external display like a charm. I’ll appreciate any solution, advice, schematic and etc. Thanks in advance!

Kind regards!

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 2
Voeg een opmerking toe

3 Antwoorden

Het nuttigste antwoord

If an external monitor is working that nails it down to the internal display and its connections and the backlight logic.

With everything connected using a flashlight pressed on the screen at a sharp angle are you able to see the faint image of your desktop and the icons on it? If you are your backlight cables & logic needs to be checked out. If you don't see anything in a darker room restart the system to you see a quick faint glow during the boot up (sometimes you might not see it)? If you do then the sync cable is bad.

Otherwise the display its self likely needs to be replaced. Did you bang or drop the system?

Was dit antwoord nuttig?

Score 1

Commentaar:

Dear Dan,

I checked everything. No signal at all. May be videocard is dead. It’s Ati 5750 1GB. Would you advise for possible substitutes! I read that some people have used even 6000 series.

door

Voeg een opmerking toe

"Video card" is live because external screen works. Should be back light problems. Can you give me you logic board model?

Was dit antwoord nuttig?

Score 0

Commentaar:

Actually I checked. No external too. Nor a sign. If you watch at angle, no icons and etc. The interesting thing is that there is no fault signal at startup. I will be able to provide serial tomorrow as the comp is not with me. I’ts early 2010, iMac 27” i7

door

The first problem of the comp was that there was a problem with fan controls. As a result it became too hot. I resolved a problem. It was one of the temperature sensors, but lost the video.

door

Do you have hot air rework system? As u have mentioned that it was overheating in the past. And mac is standing vertical... your "video card" might be desoldered it self... yiu will need to bake it with hope that it will work out. Almost same thing what people was doing with. Xbox 360

door

Voeg een opmerking toe

Just a dead lcd on the main display. The fact that you are able to view on a separate display means your video card / motherboard are working fine. Just need to replace the main lcd. no need to over complicate it :)

Was dit antwoord nuttig?

Score 0

Commentaar:

May be I didn’t explain well.. It was reported from a local service that the external display works. But actually when I checked, it doesn’t. Neither external ot internal work. No fault sound. I checked the video cable. It seems to be OK.

door

Voeg een opmerking toe

Voeg je antwoord toe

Ivan Hassamski zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 1

Afgelopen 30 dagen: 1

Altijd: 172