Ga door naar hoofdinhoud

Repareer je spullen

Recht op reparatie


Late 2011 model, A1278 / 2.4 GHz i5 or 2.8 GHz i7 processor.

638 Vragen Bekijk alle

Folder with flashing question mark and recovery problem

My 13 inch MBP does not boot with the recovery partition missing or startup disk missing. Tried to boot it with "Option + R" combination but it did not work. It took me to the internet recovery mode through wi-fi. I followed the link

1. I opted for preparing a bootable installer on flash drive. Using another mac succeeded in making a flash drive with "Install OsX El capitan app" and followed the instructions exactly as given in the link.

2. Attached the flash drive to the system with problem and tried to boot it.

3. The start up device list showed two options

a) wi-fi,

b) a yellow drive with "OSX El Capitan" below it. Clicked that.

4. There was a progress bar which was followed by another progress bar finally the "disk utility window" appeared (picture attached)

Block Image

Block Image

Here I am supposed to select the "Internal drive" . But I don't see that. Some pictures of my progress are attached. I see one external drive and two disk images. Don't know what to do.

I request some experts to help to sort out my problem. Thanks.

Update (05/28/2017)

Hi Mayer and Arbaman, here is a pic of the drive with a USB to SATA adapter.

Block Image

. Now I need to test it.

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe

2 Antwoorden

Gekozen oplossing

It appears either your hard drive or hard drive cable has failed, or both.

Remove the drive and test it using a USB to SATA adapter or an external enclosure.

Also take a close look at the hard drive cable where it comes over the last step and see if it shows any marks where the bottom may have been contacting it.

Was dit antwoord nuttig?

Score 5


Hi Mayer, all my problems started with a RAM up gradation. I tried to put 2x 8Gb ram modules into 2x2Gb. Immediately following that there was this problem of HD not identified. I went for a PRAM reset and everything was fine. It rebooted showing the actual RAM. Then it went for a number of updates (the system was not updated for quite some time). Everything was fine. Then after a couple of hours it was shut down. The problem happened when I tried to reboot again. And that is where it is now. From this I believe, the connector must be ok. It could be the HD. That needs to be checked. Do you have any other suggestion ?


Replace the old RAM and see if your problems persist.


Pics of the results I uploaded are with the old RAM. I have managed to get a SATA to USB adapter from an external hard drive (pic attached). I was trying to test this drive with my macbook air. But I am afraid, there is already a "Macintosh HD" drive on the mac air and loading the second "Macintosh HD" (the suspect HD with the same name) may lead to a trouble. Don't to think so ? Please suggest. I am afraid of renaming my Macintosh HD on my mac air to carry out this test. Thanks.


Sorry forgot to attach a pic. I don't know how to add a pic in the comment. But the drive is ready to be attached as an external drive in a working system.


Don't worry about changing the hard drives name. BUT this is the first mention you have made about this being a MacBook Air! Please verify your exact machine.


16 commentaren meer tonen

Voeg een opmerking toe

The two easier options here appear to be: faulty hard disk, faulty hard disk cable/connector. Do you have any alternative hard disk you could plug in for a try ?

One thing I cannot understand though is the size of the drive you selected in the picture as I cannot remember of any Osx install disc of only 1,3Gb ?!?

Do the drives shown by disk utility make any sense to you ?

Was dit antwoord nuttig?

Score 2


Hi Mayer and Arbaman, thank you for your prompt suggestions. Indeed the I don't get any thing out of the disk images. Actually the bootable flash drive I had prepared has only one file "Install OSX El Capitan app. And where are the disk imges coming from? I was thinking I would get an internal drive where I can install El Capitan from the external drive. Looking at the disk images and not getting the internal drive made me nervous. I had checked for the HD connector. Did not find anything. Still put a thin layer of insulation film below it so that there is no sorting to the body. That did not help. I am going to arrange a USB connector and see whether I can use the disk as an external drive in another mac. I do have a hard disk and and have to see whether I can prepare it (taking out the cover ) to plug in and try as you have suggested.


Voeg een opmerking toe

Voeg je antwoord toe

Durga Mahapatra zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 1

Afgelopen 7 dagen: 3

Afgelopen 30 dagen: 24

Altijd: 13,000