Ga door naar hoofdinhoud

Pentium M 1.6 GHz, 512 MB RAM, 40 GB HDD

17 Vragen Bekijk alle

Why can't I turn on the laptop?

I've been unable to power up the laptop. Not sure why, but I do know someone turned off the power to my AC adapter (my battery died a few months ago, so I don't use one) and I haven't been able to turn on the laptop ever since.

When I connect the power cable to the laptop, the power symbol (the two-pin head icon) lights up. However, when I press the power button, nothing happens and the two-pin head icon goes out. If I remove the power cable and plug it back in, the symbol lights up again.

Anyone think they can help?

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 2

Commentaar:

Were you able to resolve your problem? I am having the exact same issue. Thanks.

door

momocha, that question has not been answered since Nov 2010. You get better help if you ask your own question, it is not difficult to do and anybody will se you asked for help. Good Luck

door

Voeg een opmerking toe

5 Antwoorden

Het nuttigste antwoord

Try unplugging the laptop (normally you'd remove the battery also, but you've got that covered!) and holding down the power button for a good 10 seconds, then plugging it back in and turning it on. I've straightened out several Thinkpad / Lenovos that way when they exhibit the symptoms you describe.

Was dit antwoord nuttig?

Score 1
Voeg een opmerking toe

Could be a RAM issue. On this model I believe that there is one stick on the bottom and one underneath the keyboard. Try removing one at a time to see if either might be causing the problem.

Was dit antwoord nuttig?

Score 1
Voeg een opmerking toe

Same Problem i had back then with another Laptop. It was some dried-out condensers in the near area of the power jack.

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

your laptop had a Short circuit!

Was dit antwoord nuttig?

Score -1
Voeg een opmerking toe

I got my IBM X31 fixed with the same issue. Turns out to be that the connections on the port needing bending back into shape and spraying with switch lubricant. Now it works fine.

Try applying pressure on the power connector to see if power comes on intermittently. If so, it might be the same issue as mine.

Was dit antwoord nuttig?

Score -1
Voeg een opmerking toe

Voeg je antwoord toe

Jonah Sun zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 0

Afgelopen 30 dagen: 2

Altijd: 6,829