Ga door naar hoofdinhoud

Model A1051 / 4 of 6 GB harde schijf

88 Vragen Bekijk alle

After replacing my Logic Board why does my Display not function?

Okay I'm looking for some help fixing my 1st Generation iPod Mini, I got it broken from a friend and when I first got it I plugged it into iTunes and got no response at all. I then brought a replacement battery from iFixit and installed that at which point the iPod did boot, I can only assume from some residual power left in the battery, and displayed the sad iPod icon and wouldn't go any further. I then took this to mean that the logic board was gone so I ordered and replaced the logic board but after I had put in the board and was connecting the display cable back to its relevant connector I noticed the connector on the new board was bigger than the old one but I simply reconnected the cable anyway and continued. Now when I connect the iPod to power I don't get any kind of screen response but I can hear the hard disk heads moving so there must be power in the board. I've begun to think that the display connector is the problem but does anyone have any insight with which they might be able to help?

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Een opmerking toevoegen

1 Antwoord

Het nuttigste antwoord

You may have ordered a logicboard for a 2nd generation mini, which has a different LCD and connector. You'll have to now find an LCD for a 2nd gen mini, or find another 1st gen mini logicboard.

Was dit antwoord nuttig?

Score 1
Een opmerking toevoegen

Voeg je antwoord toe

Zagreus zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 Uren: 0

Afgelopen 7 Dagen: 0

Afgelopen 30 Dagen: 0

Altijd: 1,161