Ga door naar hoofdinhoud

Repair guides and support for phones manufactured by Oppo Electronics Corp.

286 Vragen Bekijk alle

Why is my phone cannot be on?

Nothing appears on the screen except the word OPPO.

I switch off the phone and restart but only the word OPPO appears.

What should I do?

Thank you.

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 44
50 opmerkingen

Its not working


its working :)


Hi, my phone cannt be switch on. But when i charge it, it shows that the phone has very low batery with red signal. So it told me to charge the phone first, but i already charge it for 6hours plus and it still cannot be open. My battery is built in. It only show oppo words when i tried to open, but suddenly it blank back. Is that because of the battery or the software? I already update the software before this. Please help me


My oppo phon accaunt tecnologe delete oll.?


2% charger oppo phone got swithched off. When I connecting to charger... there is so charging symbol. After few min I try pressing volume up n power button . No reaction . It's not switched on ?

Bought a phone a month ago. What to do now only…. It's a



45 commentaren meer tonen

Voeg een opmerking toe

2 Antwoorden

Gekozen oplossing

Your phone might have bootloop caused by software problem and it could be solve by hard reset. Hold volume up and power button at same time until screen shows oppo and small recovery mode text below. Just follow the wizard on screen to reset aka format and wipe cache so on.

There are also way to reset using pc and you can find tutorial on how to do that googling oppo hard reset or unbrick oppo. Mine has same problem too but it cannot enter recovery mode or recognized by pc. So just waiting for expert help on this

Was dit antwoord nuttig?

Score 26

14 opmerkingen:

I'm done hold volume up and power button at the same time and it shows fastboot so can i get next step ?


hi sophie. i'm sorry if its too late but i will share this just in case

before entering fastboot, you have to download your phone firmware from internet first. make sure you find firmware for correct model number to avoid other problems.

put it on sd card and insert into your phone

enter fastboot, choose wipe data and cache first to clear your existing firmware files from affecting your new firmware installation

then find install from sd card, and look for firmware files you put on sd card to install new firmware. proceed until installation complete and phone restarts

make sure before you do these steps, CHARGE your battery phone fully to avoid disruptions on install. if your install stops suddenly because of low power, it can cause big problem


Thank you ! It really worked.


What should happens after updating the firmware? My nothing is changing.

All I can see is 'oppo' and recovery mode text.


I cant reboot my phone it is asking my lockscreen password


9 commentaren meer tonen

Voeg een opmerking toe

hi, farah

i think it's not a big problem try to get the battery out and put it again , also don't forget to give your oppo few minuites to refresh before use it again , i hope it works with you .

Was dit antwoord nuttig?

Score 0

4 opmerkingen:

My phone oppo a1k is not being on when the battery was 23% so i put it in charger and then the charging sound comes but its not being open

What should i do??


my phone oppo 19 pro. it's not getting on. what should I do?


may i know why my oppo A12 don't have Region?


My phone suddenly shut down. It was working a while ago and i charged it. I tried to press the power botton but it is not working. also tried to hold the volume up and power botton but it wont work. Hope you can help me also with my problem. Thanks


Voeg een opmerking toe

Voeg je antwoord toe

farah wahida suhaimi zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 26

Afgelopen 7 dagen: 176

Afgelopen 30 dagen: 832

Altijd: 95,421