Skip to main content

13" aluminum unibody, 2.0 or 2.4 GHz Core 2 Duo processor.

624 Vragen Bekijk alle

Ram port not working

Hi folks,

So I have 2x4gb ram sticks with the most updated EFI for my Macbook 5,1.

Put both sticks in and my system information says only 4gb recognized. Removed one stick and tried on both RAM ports. The top port works fine, the bottom port doesn't work and the system won't start and beeps once every few seconds. Has anyone encountered this problem and does anyone have any suggestions as to how to fix it?


Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 1


There are 12 different A1278 models, let's nail yours down. What are the specs on your RAM chips? Are they identical? Do you have the original sticks?


I tried mentioned soultions like unscrewing screws of motherboard (3 pcs) and Memory banks (4 pcs), but to no avail! Then I found this solution on the Internet:

Just an A4 folded and cut to approx 16 layers (=2 mm), clamped in between the two modules and then fastening the screws again did the job for me! YES!!!!


Een opmerking toevoegen

MacBook-reparatiesets voor batterijen

Vanaf $69.99

Buy Now

MacBook-reparatiesets voor batterijen

Vanaf $69.99

Buy Now

3 Antwoorden

Gekozen oplossing

Hey folks

Thanks for getting back to me.

Just wanted to update everyone to say that I fixed the problem. Looking through the other questions asked I found this

Bank 1 Memory Slot not recognizing RAM--easy way to fix?

And in the comments saw Jay Arvidson had suggested slightly unscrewing the ram slots on the motherboard.

I loosened them ever so slightly and BAM now my computer is running 8gb. Also just upgraded to a SSD and I feel like I'm running a new computer.

Absolutely fantastic stuff.

Thanks for everyone's help!

Was dit antwoord nuttig?

Score 1
Een opmerking toevoegen

Hey there Nik.

Sounds like a bad ram slot.

It's made out of many pins, you can look into the slot and make sure the pins are aligned correctly and not bent.

I've fixed a few just by bending the pins back.

There is also an IC chip on the motherboard that may not be working properly. We've repaired issues like this as well.



Was dit antwoord nuttig?

Score 0
Een opmerking toevoegen

I have a similar problem however it's a bit strange.

I have an iMac mid 2011 i5

For a period of time I had 2 ram X 2GB and 2 ram X 4GB a total of 12MB

Recently the slots of the 2 rams of 2GB appear empty.

Ok... I bought another 2X4GB to replace them and to upgrade the total memory in 16GB

I put the new couple but again only the 2 already installed chips regognised (the down couple- bank 0 and 1 in Dimm 1) The upper part (Bank 0 and 1 in Dimm 0 appear empty)

First thought were that the ports had an issue as described in the thread.

Of course I have checked all chips individually and all are ok.

The strange part is that the upper slots WORK normally and recognise the chips IF the down slots are empty.

If ALL slots have a chip inside, only the down couple of chips (Bank 0 and 1 in Dimm1) is recognised.

So, neither the chips have an issue nor the slots...individually.

I will appreciate any idea!

Was dit antwoord nuttig?

Score 0
Een opmerking toevoegen

Voeg je antwoord toe

Nik zal eeuwig dankbaar zijn.

Afgelopen 24 Uren: 0

Afgelopen 7 Dagen: 4

Afgelopen 30 Dagen: 29

Altijd: 1,107