Why won't my nexus 4 turn on?

Hello, I just bought a used Nexus 4, apparently just had a dead battery. Put in a new battery that came with the Nexus and charged it for over 2 hours, nothing turns on. Tried the hold volume up + power for 60 sec, and also hold volume down + power for 90 sec, neither worked. I opened the Nexus 4 up and saw that the charging port was missing the gold foil.

Would that be the problem? Or should I just buy another battery and see if that works? I can't tell if the battery is getting charged or not, but the phone is slightly warm after a few hours.


Got a new charging port, it didn't come with the gold foil I mentioned. Put it in anyway, and now I get a solid green notification light, so at least I got some progress. I'm trying a bunch of different things, looked online and read a bunch of forum posts about red blinking lights or red solids, but very, very few solid greens. Anyone have any experience with that?


Got a new battery, replaced it, and it works just fine! Not sure if it was the combination of replacing the charging port and the battery or simply the battery itself. Glad it works though.

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0

4 opmerkingen:

Usually solid green means the battery is fully charged.


I see, but I can't get the phone to power on. I tried holding the power button for 15 sec and every other combination I originally did, but nothing happened. Bought a new battery and going to replace it. I wish I could see if there was a charge though.


Glad you sorted your issue! I'm having nightmare with red blinking light. Got new battery and it didnt work either.. Have to try new charging port next. was it difficult btw ?

Shame on google/lg, my 10 years+ nokias are still working.


Hey Cg Data! It was really simple to replace the charging port. I would just follow the breakdown guide. The only risk I see is damaging the antenna that's connected to the charging port/daughterboard to the motherboard. Other than that, it should be a breeze.

I would also recommend trying to charge the battery with wires, as mentioned in this handy guide:



Voeg een opmerking toe